Video Screencast Help

Run PsExec from Symantec Ghost 2.5 Console

Created: 12 Feb 2013 • Updated: 12 Feb 2013 | 3 comments

Server Box: Windows 2008 R2 x64

Workstation: Windows XP SP3 (joined to the domain)

Ghost: Symantec Ghost Console (Solution Suite 2.5.1)

I need to run a command as an account other than System, (which is the account that Ghost uses to run commands on the client system). I've tried the following:

c:\psexec.exe /accepteula -u administrator -p XXX -e C:\XXX.exe
 

It doesn't run. If I run the same command from the workstation, it runs perfectly. When I run it from the Ghost Console, it flashes an instantaneous command window but it doesn't run C:\XXX.exe.

I'm confused. The difference seems to be that PsExec is successful when run from a logged on user account (as opposed to System).

I've referenced the following threads, but they don't offer any answers:

https://www-secure.symantec.com/connect/forums/what-user-does-ghost-console-task-run

http://forum.sysinternals.com/psexec-with-symantec-ghost-console_topic7036.html

Any ideas?

Thanks.

Comments 3 CommentsJump to latest comment

EdT's picture

Maybe you should include either the local computer name, or the domain name, along with the administrator account name, so that psexec will know whether your administrator account is a local or domain account. 

You may also want to post this question in any forums that sysinternals may run as it's more of a psexec issue than a Ghost issue.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

benevida's picture

Good point EdT.  I'll be sure to post to the Sysinternals forum. 

I had thought about prefacing the 'administrator' with something along the lines of a 'local system\', but in the past I have always used 'computer name\' and I do not know the equivalent when the computer name is variable, (as when I am applying the command to a a fleet of Ghost Console targets). 

I also figured that as I ran the same exact command on the workstation itself, (in the context of a domain user) and it executed in the context of the correct account, that I didn't need to specify the 'local system\'.

Does anyone know how I preface the 'administrator' account name when the computer name is variable?

Thanks.

EdT's picture

Has the computer name been set at the time you run the script?  If so, you can read it from the environment or from the registry and then pass it to your command line.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.