Video Screencast Help

SAN Client -Need to confirm if the data is being backed using FC transport

Created: 05 Aug 2013 • Updated: 21 Aug 2013 | 10 comments
SymGuy-IT's picture
This issue has been solved. See solution.

Dear Experts,

I have setup a SAN client and I think it is setup well as I can see target devices on client and media server has two ports in target mode. Also I made sure that the Fibre Transport setting for the client is set to Always.

The master server is 7.5.0.6 clustered master server on windows 2008 R2 and media servers are Netbackup appliances 5230 with 2.5.3(7.5.0.6) code. The SAN Client is Windows 2008 R2 machine with QLogic card and installed with NBU 7506.

When i run the backup the data is getting backed up at speed of 64Mbps which I consider very low. In the activity monitor job detailed status I can see that it is using FC as transport medium and I can see that it is setting the required buffer settings for FC but the same time I see following which says there was no data sent over FC. This is very confusing. Please help me clarify this.

Report=PDDO Stats for (jum-nbu-5230b): scanned: 7270744 KB, CR sent: 1876733 KB, CR sent over FC: 0 KB, dedup: 74.2%

Regards,

Operating Systems:

Comments 10 CommentsJump to latest comment

Yasuhisa Ishikawa's picture

This means media server sent deduplicated data to Contents Router(term of PureDisk - media server its self in this case) via internal network connection. So it was counted as "CR sent" in stead of "CR sent over FC".

If you want to make sure backups go through FC, check network activity using Windows tools like Task Manager and Performance Monitor.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION
SymGuy-IT's picture

Hi Yosuhisha

Thanks for reply. Does this mean these stats are not the data been sent from client but the data send to CR itself? If so what are the scenarios the data would be sent over FC? I am confused now.

E-3S's picture

Hi,

As you mentionned you get a message like "USING 262144 data buffer size for FT" in the logs. You should also have Transport Type: FT in the detaillled status.

To be 100% sure, do a portperfshow (or equivalent) on your FC switch and check the trafic on the FC port where your SAN client is connected.

You could also disable the FC ports of you SAN client and check the differences when the backup is running through the LAN.

Hope this helps.

jim dalton's picture

Look on the san switch ports, they will most likely have some throughput stats available. If thats their only use, then its easy to see the activity.Brocade has reset and interval counts so you can null it and then  run  your tests.

Jim

Kevin Good's picture

Has the client been set to also Always use client side deduplication?  (This is not the default behavior, but may have been configured)

Client Side Deduplication and Fiber Transport are mutually exclusive.

Backups are IT-101 (Do Backups) Doing Backups well is an art form. Nobody cares about getting their data backed up... They only care that you can restore it for them!

Omar Villa's picture

Activity monitor haves a column named transport if is empty is LAN if not will say FT.

Hope this helps.

Omar Villa

Netbackup Expert

Twiter: @omarvillaNBU

Yasuhisa Ishikawa's picture

Does this mean these stats are not the data been sent from client but the data send to CR itself?

No. Data sent from client to media server via FT, then media server sent it to CR. CR is internal component of deduplication. in your case, media server is also deduplication storage server, so "CR sent" is amount of data paased from media server component to CR component running on the same host.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SymGuy-IT's picture

Hi Omar,

There is no column named FT. Though in the job detailed status it shows as FT. I am not happy with the speed it is delivering. The data is on SAN and SAN client is delivering only 54MBps.

cruisen's picture

Hi,

you should get the logs by using : ./vxlogview -i 199 -o 199 -d all

/usr/openv/netbackup/bin

"ID:199 [No context] [Info] V-199-7 Supporting 2 luns per target mode FC HBA port

07/08/2013 13:20:15.786 [Debug] NB 51216 nbftsrvr 199 PID:7027 TID:1100314944 File ID:199 [No context] 1 [InitPipe] No target mode FC ports available

07/08/2013 13:20:15.786 [Debug] NB 51216 nbftsrvr 199 PID:7027 TID:1100314944 File ID:199 [No context] 1 [nbfdrv64] exiting - InitPipe returned -1

07/08/2013 13:20:15.786 [Debug] NB 51216 nbftsrvr 199 PID:7027 TID:1100314944 File ID:199 [No context] 1 [SetLogLevel] DebugLevel changing from 0 to 1"

be sure not to have the number_data_buffers set . Nbu will use this setting for NB and overide the FT settings. As example one setting about 64 will cause an invalid parameter error in the backup because NBU can not handle more than 30 pipes.

http://www.symantec.com/docs/HOWTO56197

best regards

Cruisen