Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Scan engine install on RHEL, blank console

Created: 03 Dec 2012 • Updated: 03 Dec 2012 | 11 comments

Hey everyone,

Scan Engine has been installed on a RHEL 6.2 VM (VirtualBox), however, when visiting the console (and accepting the certificate warning), I get a blank page. No prompt for a login, no text, not even a line in the source.

Any thoughts?

Update: More information

Latest version of 32 bit Java installed and working correctly. ICAP scanning (using the command line scanner) is working correctly. Connections from local host (wget https://127.0.0.1:8004 --no-check-certificate) returns a blank page, as well as connections using Chrome, IE and Firefox (from another system on the network).

Thanks,

Dave

Comments 11 CommentsJump to latest comment

BenDC's picture

Typically one would expect to see security prompts from the browser and java. If you answer the wrong way it can cause the page to stop loading. In some cases you may need to chose "no" to contiune to load a page, where as others it is "yes".

Alex_CST's picture

There is indeed a tricky security warning if you use firefox where you have to say no instead of yes, but if you are using IE add it as a trusted site and you should be on your way.

You may (if you're using firefox) have to go into your addons and enable the java addon

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

ClementChen's picture

I have the same issue. I tried both 32-bit and 64-bit Redhat Linux 6.3 and the admin console did not work in both cases.

The installation is successful and the scan engine seems to be working fine. But I cannot use it without access to the admin console.

Any help would be appreciated.

dasfx's picture

A note: This never got fixed. Contacted Symantec Support and sales, and never recieved a call back.

Additionally, the certificate information is helpful, however, the wget command line I included specifically disables certificate validation for the request.

Thanks,

Dave

BenDC's picture

I would not expect wget to show anything really as it is only going to attempt to load the applet. If the connection can be made it is likely a java issue, not a scan engine problem.

If you are using a broswer from redhat or other linux box, you may need to ensure the java plug in is registered/enabled.

Can you access the Web UI for the Scan Engine from a windows machine on the network?

dasfx's picture

BenDC,

I should at least get HTML back which would include the code to launch the applet (applet or object tag). Otherwise, how would the web browser know that it even needs to run Java?

Yes, this was tried from a few different browsers (IE, Firefox, Chrome) and platforms (Windows, Linux).

Thanks,

Dave

dasfx's picture

Tried this again. New VM, running in VMWare, CentOS 6.3, iptables off, SELinux off. Still the same result. Attempting to load the web console gets a "connection reset" (Firefox) or "No data received" (Chrome).

Dave

IBMLinuxAdmin's picture

Hello,

i have the same problem in a VM running in RHEL 6.3 .

Blank page when i launch the web console (https://servername or IP :8004).

java 32bit installed ,but java doesn't start when i launch the web console i don't have the security warning from java ect...

do you have a idea please ?

Thanks

fabricapo's picture

I have the same exact problem. I tried with every browser and Java combination, but the page is always blank.

Is there a way to increase the log level of the server, so we can understand where the problem is?

I am evaluating the use of the server for a large deployment, and if the problem persists, I will look for a different product.

Thanks,

   fabrizio