Video Screencast Help

"scan for viruses" in the context menu is missing

Created: 04 Mar 2009 • Updated: 29 Jun 2010 | 10 comments

i have sep mr3 on winxp sp2 computers'

i dont have the command line "scan for viruses" in the context menu

how i'm bringing it back?

Comments 10 CommentsJump to latest comment

brav's picture

Are you using the SEPM account that you set when installing SEPM ? It sounds like you don't have permissions.

 

 

m00

shlarki's picture

i didn't change the default policy.

i didn't c at the policy that it can b blocked

RickJDS's picture

I've never seen that option on a client in windows explorer, so maybe I'm missing something.  If you're talking about the console, you can right click on a client/group and choose run command on clients / scan.

Renegade's picture

He is talking about a client. When you right click a file or folder the option to scan for viruses is missing.

I have the same issue and have found that the scan for viruses option only seems to disappear if i RDP to a client. In an RDP session the scan for viruses option does not appear. However, if i log in to the physical machine everything works correctly and the option to scan for viruses is present.

This is a big issue for me as we have close to 1000 virtual clients conencted via Sunray or Wise terminals.

Still trying to work out if it is a Microsoft issue with RDP itself of an issue for Symantec to resolve.

Sandeep Cheema's picture

HKCR> *> shellex> ContextMenuHandlers> LDVPMenu is only available locally on the box, not through RDP.

De facto when AV does something, it starts jumping up and down, waving its arms, and shouting...

"Hey!  I found a virus!  Look at me!  I'm soooo goooood!"

ShadowsPapa's picture

SAV and prior AV apps had the context menu modified when you installed them.
You could browse to a file in explorer, right click on it, and choose to scan for viruses.
SEP has dropped that. Sad, very sad, as it was SURE handy!
It's not on any of our computers any more - since installing SEP.
--edit------------
I take that back! I found it on a notebook - but it's sure not on my other computers.........
Could it be that if you have ever remoted to a different computer that it removes that option from the computer you are on?
It's not on VISTA at all.
I found it on one XP notebook..........

Sandeep Cheema's picture

ShadowsPapa,

I more or less agree with you. I have seen that as well. The "Scan for virus" context menu is missing on "32 bit \ Client OS \ locally logged in" machines as well.

De facto when AV does something, it starts jumping up and down, waving its arms, and shouting...

"Hey!  I found a virus!  Look at me!  I'm soooo goooood!"

RickJDS's picture

It's not available on Windows 7 64 bit client.  I've only seen it on XP 32 bit with 32 bit clients (MR4).

Symantec World's picture

The Scan for Virus option will not work on 64Bit OS.

Regards, M.R

Ludikraut's picture

Unfortunately there doesn't seem to be a very elegant solution for this, but you can at least reduce it down to two mouse-clicks ... (like I said, not quite as elegant as one mouse click, but...)

*** NOTE *** I tried this on Windows XP 64-bit.  I have no idea if this exact method will work on other MS 64-bit OS'.

Insert a new context menu entry in the 64-bit explorer by either:
A.
- go to [Tools] > [Folder Options] > [File Types]
- find the "Folder" file type and click on [Advanced]
- create a new entry by clicking on [New]
- Name the new entry in the Action field (I called mine Explore 32-bit)

- In the "Application used to perform action" field, enter the following command (for some reason I had to hard code the path instead of referring to the SystemRoot variable:
C:\Windows\SysWOW64\explorer.exe /separate, e/,%1

- Click [OK] to save the new entry

- OR -
B.

Copy this text into a .reg file and import it into your Windows XP x64 registry:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Explore_32-bit]
@="Explore 32-bit"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Explore_32-bit\command]
@="C:Windows\\syswow64\\explorer.exe /separate, e/,%1"

You should now have a context menu entry in your 64-bit explorer that will allow you to open a folder in a 32-bit explorer window.  So if you want to scan a specific file, right click on the folder containing the file, select [Explore 32-bit], and the folder should open in a 32-bit Explorer window, where you can then right-click on the file you want to scan and select "Scan for Viruses".

HTH.

l8r)