Video Screencast Help

The schema version in the chosen data file is higher than the server schema version

Created: 20 Sep 2013 | 8 comments

Hey All,

I'm moving a SEPM 12.1 embedded database to a new partition using the SOLN 3. procedure from the following link http://amwww.symantec.com/connect/forums/out-disk-space-sepm-move-sepm-another-drive. At step 10. the Backup and Restore utility gives the error message "The schema version in the chosen data file is higher than the server schema version. Restore is not allowed. The restore process will now exit. I've tried twice with the same error each time.

 

Please Advise,

Operating Systems:

Comments 8 CommentsJump to latest comment

_Brian's picture

So you're just moving to a new partition, not a different SEPM?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Rafeeq's picture

It is important to have the same version of database schema used during installation.

Symantec Endpoint Protection Manager (SEPM) installation returns the error: "The server schema is older than the database schema, the configuration cannot continue."

http://www.symantec.com/business/support/index?page=content&id=TECH178820

Here are few steps you could try - 

  1. Run the upgrade wizard located: 'C:\Program Files\Symantec\Symantec Endpoint Protection Manager\bin\upgrade.bat'
  2. Run the Management Server Configuration Wizard again to complete the migration process.

This issue is similar to the Thread below:

https://www-secure.symantec.com/connect/forums/problem-upgrading-sepm-121-sepm-121-ru1

Mithun Sanghavi's picture

Hello,

This Error "The schema version in the chosen data file higher than the server schema version. Restore is not allowed. The restore process will now exit." occurs when you are trying to Restore a backup of Database from an older version of SEPM to an higher version of SEPM.

Could you please let us know, What was the version of SEPM installed when the backup was taken?

It is recommended to install the same version of SEPM which was installed on the earlier server.

Can a backup of SEPM from a previous version be used on a newer version of SEPM?

http://www.symantec.com/docs/TECH105147

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

drreid's picture

Hey Brian,

Yes, I'm just moving it to the D: partition which has more space.

Hey Mithun,

Unfortunately, deleting SEP was back on step 3 of the procedure in the link from my previous post. In my downloads folder I have Symantec_Endpoint_Protection_12.1_Full_EN.exe which what I installed at step 5. I tried to download a later version, but I don't have the correct code. I'll try yours and Rafeeq's suggestions.

 

drreid's picture

Rafeeq's suggestions didn't help. I assume that since I'm not sure what version I had when creating the database (before deleting SEPM from C:), I'll need to upgrade my current 12.1 SEPM to the latest version to ensure the database schema isn't from a higher version?

 

Thanks In Advance,