Video Screencast Help

SCSP Agent installation caused infinite loop reboot in an AIX Server.

Created: 11 Sep 2013 | 10 comments
itsmeLuck's picture

Hi team,

 

Have anyone experienced this kind of issue, as we all know to complete SCSP agent installation it requires to reboot the server however after rebooting the server it never went back up it keeps on doing a loop reboot. We already had this issue a few days ago with the first AIX server we installed an agent in after the required reboot the server never went back up and we called an AIX support we already deleted all files created by SCSP agent however the server still wont go pass NFS boot. We thought SCSP was not the reason of the infinite reboot so we created a new AIX server unfortunately the same issue of infinite reboot still happens.

For added info the SCSP Management server is installed in Windows 2008 R2 Standard SP1 and the AIX version where the agent is installed is AIX 6.1.

I hope you can give us a help with this issue.

 

Thank you,

Operating Systems:

Comments 10 CommentsJump to latest comment

Chuck Edson's picture

I just checked our bug track system for all 5.2.9 versions of our AIX agent, and did not see any reported cyclical reboot issues.

Can you get the core files to send to support?  If so, I would open a ticket with support and get the core files analyzed to see what the root cause of this may be.

One thing to try is edit the inittab file to not load the sisips driver as a test and see if that allows the system to boot.  If you can get the system to boot, grab not only the core file(s) but also run the collect agent info script, as support will want both if possible.

If a post helps you, please mark it as the solution to your issue.

Shulk's picture

What is the TL of your AIX 6.1 server?

The reason I am asking is that there are still issues with specific TL.

IBM has changed aspects of how AIX allows 3rd party products to access certain network information. A ticket has been opened directly with IBM engineering in order to find a way forward.

Have a look at Symantec Critical System Protection causes AIX 6.1 TL8 systems to reboot

Please let me know, thanks a lot!

 

Chuck Edson's picture

Good call Shulk . . . 

If a post helps you, please mark it as the solution to your issue.

itsmeLuck's picture

Hi Chuck and Shulk,

 

We looked at the AIX 6.1 server and saw that the TL of the AIX 6.1 is "8" in which as per Shulk's link it is exactly the AIX 6.1 TL which is not currently supported by SCSP. Is there any other AIX 6.1 TL's that are not supported by SCSP? 

 

Thanks a lot for giving me great help guys!

itsmeLuck's picture

Hi Chuck and Shulk,

 

We tried to edit the inittab to not to load the sisips and sisids drivers and it went back up, the system booted with no problems.

 

Thanks,

itsmeLuck's picture

Hi Chuck and Shulk,

 

Do you have an idea when would TL8 systems be compatible with SCSP 5.2.9?

 

Thanks,

Chuck Edson's picture

itsmeLuck,

I do know that compatibility with TL8 is on Engineering's radar, but as of yet it has not been targeted for a specific build.  You are not the only customer that has this compatibility issue.  

Do note that because Symantec thinks that this may be a bug in AIX, there is a slight possibility that we make skip TL8 completely.

If we see a patch from the AIX folks that repairs this, I will try and remember to update this post with that information.

As far as I know, TL8 is the only TL that we have issues with.

Note, that you should still be able to use the IDS driver, as it is not a kernel mode driver, so that will at least offer you detection.

 

 

 

 

If a post helps you, please mark it as the solution to your issue.

Shulk's picture

Yes, the issue was faced only on TL8 because again, IBM has changed aspects of how AIX allows 3rd party products to access certain network information. However, there are some concerns as well for AIX 7, but it should all be resolved at the same time.

So for know and as per the KB, the workaround is to only use the IDS feature.

Also, I would recommend you, once the CSP agent install with IDS only, to restore the inittab to its original values since we noticed (during our testing) that it can lead to unwanted effects.

You should subscribe to the KB Symantec Critical System Protection causes AIX 6.1 TL8 systems to reboot to be informed as soon as there is an update.

Shulk.

 

VKalani's picture

Hey, This seems to fixed in mp4 for 5.2.9

You must apply IBM APAR fixes for this to work

-VKalani