Video Screencast Help

SDR Not showing disk layout

Created: 15 Feb 2013 | 6 comments

Hi All,

I have never used the BE 2012 SDR to recover a complete server before.  I do run an SDR backup on a few of my servers though.  I have a test box I am trying to restore a SDR backup to.  I have made the recovery boot disk from within BE and created the .ISO file to burn a CD disk image.

The recovery disk boots and installs and starts the network drivers and I can see the BE media server.

I can see the recovery point on the media server I want to recover. I can select that recovery point and it brings me to the disk layout.

This is where I have trouble.  First the disk layout (Volumes) screen that shows first is blank. Under Preview I show my unformatted disk with no partitions.

So it doesn't matter if I check the box that says erase the partitions and replace or not.

If I go into advanced disk layout, it shows me what I believe is my orginal disk layout for the server I am trying to recover.  I can create partitions on the disk layout there.

When I return to the volumes screen it is still blank and I can not click "next" as it is greyed out.

I thought well maybe it doesn't have my raid controller driver loaded.  So I went out to the first screen and to utilitites and loaded the specific RAID controller drivers. Then went through the wizard steps again until I get to the disk congiuration, and volumes show blank still. If I go back into advanced I can again create and format partitions, but still no way to click next on the disk config screen to go further.

Since I have never run through this procedure before, I feel I must be missing some little thing that would let me continue.  But honestly I don't really know what to expect for any of these screens.

What I think I should expect in the disk config screen (I think it has been refered to as the quick view) is what my disk currently looks like.  This would then make the check box to erase what ever is showing and replace it with what the recover needs.  But in every case it doesn't show anything in this view.

Have I missed something some place?

Any help will be appreciated.


Kevin Pulford

System Administrator

Harmon City, Inc.

Discussion Filed Under:

Comments 6 CommentsJump to latest comment

pkh's picture

Are the disks that you are trying to restore to the same size or bigger than the disks of the original system?  For example, if the C: drive of the original system is 100GB, then the disk for the C: drive restoration must be 100GB or more.

KevinP's picture

Thanks for your response.

In my test environment, the disk size is less than 1 gb smaller.  But there are two partitions, so I can give the C: drive the full 80 GB but my E: drive is 384.5 insteadof 385 from the original.

Now let me say that if I could jut lay down the c: drive, I could then ata restore the E: drive andeverything would be perfect.

In any case, niether the c: or the E: drive were near full. The entire SSR backup was 140 GB, that included both drive partitions.

Does that mea this is not viable as a recovery option since I am .4 gb sort of the orginal disks?


Kevin Pulford. 

KevinP's picture

I am still a bit confused as to how this SDR is supposed to work.  Or I should say it is not working how I think it should work, or how I have read documents describing the recovery process.

However, it appears that the recovery I was trying to accomplish when I orginally posted, would not provide the disk layout needed, or allow me to impose my own layout on it.  (Is this a bug or a feature?) 

But if I skiped ahead a few days, I was able to pick a recovery point that did provide a layout and all the recovery seemed to go as I have read it described, with the exception of the reboot and the server actually working. :-)

So now my question really is, why would some recovery points work properly (to the actual recovery steps prior to final reboot, than others?  I mean are there certain circumstances that could affect this? I mean other than not getting a qualified SDR backup.  According to the logs all of the backups of this server have completed with no errors, and are SDR qualified.

And I am sure this will be a new post as well, since the actual question is more to do with the reboot / reconfiguration,  and then a reboot to allow the system to boot up.

Now for this question that might need a new topic.  After the SDR recovery, and the first reboot, the system appears to go through what I can only describe as some finalization or fix up from the recover.  But the system does boot to this point and spend a few minutes going through something. The screen doesn't really say what its doing specifically.  Then the server reboots again, and this is where the recovered machine started a quick blue screen then immediate reboot loop.

So I can't seem to pause the blue screen or anything else to see where its failing.  Also, booting into Safe Mode doesn't seem to allow any more control of this.  Now I suspected drivers in the first attempt, so when I made the  second SDR boot CD image, I tried to add in the specific drivers for the controller (RAID 1 RAID set) Dell H200 RAID controller.  But Symantec always says it has a newer version already installed.  So it would appear this isn't it, and the system does at least appear to boot strap.

The base OS of the recovery image is Windows Server 2008 standard (32 bit).  I am using the 32 bit boot disk image downloaded from symantec for BE 2012 SP1.

I guess at this point my real question is:  Any ideas on my next steps to complete this recovery?  I mean has anyone had any experience with this type of thing and found away around it to get the recovered system to finally boot?

For my part I am just running tests on a server mock up.  But to be clear the server I am trying to recover is a Dell PE 310 and the server I am putting the image down on is a Dell PE 310.  There are some small hardware differences between the two servers, but they appear to be minimal.

Any suggestions or questions would be appreciated.

Thank you all for your time.


Kevin Pulford

WTulaba's picture

I did see in my searches that the disk size has to be = or > than the original. Try just restoring the C: Drive to see if it completes until you can get you hands on larger drives.

KevinP's picture

Thank you for your response.

I just tried to go in and just recover the C; drive, however, it would let me select just c: and system state or unslect my larger partition from the recovery point selection.  Even if I uncheck the box that says " Recover the entire computr with this point in time backup set."

I show three backup oints in the box below. E:, C: , System state.  But unchecking the box I listed above, will not let me deselect the various partitions in the box below.  They remain greyed out.

Any ideas on this?  I have less than 500 MB of drive space difference between the server the SDR was made of, and the system I am restoring it to.  And to be honest they are the same drives, just seems like the controllers use slightly different space allocations for the raid sets.  Unfortunately I can't seem to get the RAID controller to adjust the allocation to squeek out the extra space.

Again thanks so much for your reply.



WTulaba's picture

So you select the point in time, then uncheck "Recover the entire computer with this point-in-time backup set" and then default select are C: and "System State"?