Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Search-Assets cmdlet

Created: 11 Sep 2012 | 5 comments

Anyone know what/where to set the operation timeout value? I am running the PowerShell Search-Assets cmdlet and when it hits just over a thousand devices, the cmdlet dies/times out. Less than that is successful.

(by casting the channel/proxy to IContextChannel and setting the OperationTimeout property)

 

PS C:\Users\userx\Documents> get-date
Search-Assets -AssetType "Windows Machine" -NumberOfObjectsToRetrieve 1100
get-date

Tuesday, September 11, 2012 12:48:18 PM
Search-Assets : This request operation sent to net.tcp://hostname:portnum/CCS/Services/Applications/AssetSystem/IAssetService/WindowsSec
urity did not receive a reply within the configured timeout (00:01:00).  The time allotted to this operation may have been a portion o
f a longer timeout.  This may be because the service is still processing the operation or because the service was unable to send a rep
ly message.  Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the Operati
onTimeout property) and ensure that the service is able to connect to the client.
At line:2 char:14
+ Search-Assets <<<<  -AssetType "Windows Machine" -NumberOfObjectsToRetrieve 1100
    + CategoryInfo          : InvalidOperation: (System.TimeoutE...ProcessRecord():TimeoutException) [Search-Assets], TimeoutExceptio
   n
    + FullyQualifiedErrorId : SearchAsset,Symantec.CSM.PS.Assets.SearchAssets
 
Tuesday, September 11, 2012 12:49:25 PM







Discussion Filed Under:

Comments 5 CommentsJump to latest comment

cmccoy2's picture

I am not sure what the "get-date" functions are doing before and after this statement but I ran a search-Asset cmdlet with no issues on 6000 objects in my CCS Asset system with this command:

Search-Assets -AssetType "Windows Machine" -NumberOfObjectsToRetrieve 6000 | Export-CSV -NoTypeInformation "SearchAssets.csv"

This ran with no issues.  before I ran this I had done this:  $AppServerNameAndPort = 'appservername:1431'

What version of CCS are you using and is your Directory server on the same machine as your App Server?

 

magstripe's picture

get-date is there to time the start and end of the Search-Assets function. As the number of assets retrieved grew to just aroud 1000 - elapsed time would take just about a minute. Over that it fails; under it it succeeds. I too have to add the server:port connection and add the snapin before running. CCS 10.0 and APP and DIR on the same machine.

Do you know where to check / set that timeout value of 01:00? What is it set to on your 6000 object server?
 

cmccoy2's picture

It looks like there are some timeout settings in the AppserverService.exe.config in the ...\Symantec\CCS\Reporting and Analytics\Application Server Folder.  Not sure exactly if this applies to the timeout with the cmdlets, but maybe it would help.  All of my timeouts are set to defaults as far as I am aware.  I am using CCS 10.5.1 PCU 2012-1.  hope to be applying PCU 2012-3 soon.

magstripe's picture

I missed this reply, thanks. Will give it a shot and update the thread. Are the setting changes to AppserverService.exe.config immediate or require service recycling? Other? Thanks again.

cmccoy2's picture

I know the settings for the log levels are immediate, but I am not sure about the timeout settings.  It probably wouldn't hurt once this is changed to do at least a "sync configuration" in the Settings>System Topology, but a service restart would make sure that the new settings are applied.