Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SEP 11 MR1 vista 64 bits re installation fail

Created: 22 Jan 2008 • Updated: 21 May 2010 | 12 comments

Hello Guys,

I tried to reinstall sep 11 MR1 but always i got a microsoft installer error "Symantec EndPoint Protection has detected that there are pending system changes that require a reboot." this happen after I reboot the machine too.

Regards

Comments 12 CommentsJump to latest comment

JohnL's picture
Hello,
 
You can look at this registry value to see what is pending: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations
 
If after rebooting another time this value does not disappear automatically, you can rename the value with a '2' on the end to clear the error.
 
Hope this helps.
mastersm's picture
Hi Guys, I have the 32 bit version 10.0.2000.1567 and am trying to install MP1. Each time I run it I get the same error that there are pending system changes. Under PendingFileRenameOperations my current value "\??\C:\msimg32.dll
"
I have tried adding a 2 after the .dll and also deleting PendingFileRenameOperations but it keeps coming back?
 
Any other thoughts?



Message Edited by mastersm on 06-20-2008 02:55 AM

psychowatermelon's picture

 i too am having this issue and have tried new installs of Vista business 32

and 64 bit as well as home and home premium on my laptop.does anyone

know why the registery resets everytime even when run as admin? and how

do i get the registry values to stick for once

Cornbelt's picture

I had the same issue so here is what I did to fix the problem. When I renamed the PendingFileRenameOperations and added the 2 or any number for that matter when I rebooted it always defaulted back to the original name. So what I did was exported the string value and then deleted it. I did not reboot. I was then able to install Endpoint 11.x on the current 64 bit Vista.Hope this helps.

 

Curtis T.

Information Technology Specialist

MCTS Microsoft Cert.Tech.Specialist

Corn Belt Power Cooperative

Message Edited by Cornbelt on 07-09-2008 07:37 AM
Message Edited by Cornbelt on 07-09-2008 07:37 AM
mjgd's picture

I had this same issue with Vista as an unmanaged client, and modifying the key did not solve the problem for me, but removing the key content completely did (not the key itself, just the value). See the following thread -- the suggested workaround came from Symantec:

 

https://forums.symantec.com/syment/board/message?board.id=endpoint_protection11&message.id=12934

 

 

Thimmaiah's picture

Hi,

 

I am a student and I am trying download the symantec endprotection. It always tell me to reboot as they are pending changes which has to be done. I have rebooted it several times but they same dialog keeps appearing. I read your solution but i didn't know how to get to this path on my computer. Please can you help me out in detail. "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations" 

 

Thanks in advance,

Dheeraj

 

mjgd's picture

Hi Dheeraj,

This is a registry modification. All warnings apply as improper changes can cause disastrous and unexpected results.  Please make a backup of your registry first. Then follow these steps:

 

Click on Start, run.

Type: regedit  

Click OK.

In the left window:

Expand HKEY_LOCAL_MACHINE

Expand System

Expand CurrentControlSet

Expand Control

Click on Session Manager

 

In the right window, you'll see a key called PendingFileRenameOperations.  Right click on it, and select Modify. Then delete the contents listed in Value Data.  Then click OK.

 

That should do it. Hope this helps.

 

Martha

 

 

Thimmaiah's picture

Hi Martha,

 

Thanks a ton for your help. It worked perfectly fine. Thank you.

 

Regards,
Dheeraj

whowhatmeasure's picture

I bought a laptop aspire 6930,with vista 64,320GB HDD,9600M GT, 4GB DDR2.

it had McAfee for trail of 30 days, so I uninstalled it, I tried to install endpoint, it gave the error mention as above(symantec endpoint protection has detected that there are pending system changes that require a reboot)  .my friend helped me out and installed this, then  I installed spy boot, cc cleaner and other software. Everything was working well for two days, then I tried to copy some documents from a usb drive.I tried to scan it, it showed scan with spybot and destroy. It took a long time (hell long time), so I went to control panel and uninstalled spybot .it did not work. So I uninstalled endpoint too. And again installed spybot again

Then problem starts.....

I installed endpoint with renaming the file pendingfilenameoperation by putting 2 at end.i did not delete \??\C:\SensApi.dll.

.it did install it however when I was trying to live update it gave some kind of error: ……………………………..error:5766880(I m not sure of this error)

Then I restarted and uninstalled spybot.

It gave me heartache...my computer started to crash. It was getting turned off without shutting down. 

 Then somehow I did install spybot again,( it was crashing in-between ,after trying to install for the  fourth time it did install spybot), then I uninstalled endpoint.

Now it is not crashing...........I m writing to you from another machine......what should I do? Please help 

whowhatmeasure's picture

This is what it's coming when i start my comp.

Spybot - Search & Destroy

Spybot - Search & Destroy has detected an important registry entry that has been changed.

Category:Session manager
Change:Value added
----------
Entry: BootExecute
----------
Old data:grayed out, nothing here for Old data
New data:autocheck autochk *\

AxnJxn's picture

Johnny,

 

It appears you might have a solution, but what if that key entry does not exist?

 

AXNJXN