Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

SEP 12.1 client installation failure

Created: 17 Aug 2011 • Updated: 31 Oct 2011 | 22 comments

I recently deployed the 12.1 client with few problems. However on one computer (OS is Windows 7 64bit.), where I had installed the client before auto-deploying to everyone else, the client is broken and won't reinstall. The problem seems to have started when I auto-deployed the client with SEPM. For some reason the problematic client accepted the autodeploy install, even though it was already on the latest version; this install broke the client. I've tried reinstalling many times, but the install always fails. I've tried deleting the SEP client remnants before installing, but with no success. Below is a snippet from the install log where I believe the install fails (full log is attached).

MSI (s) (B0:B4) [19:03:06:842]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIAB17.tmp, Entrypoint: AddCacheAsInstallSource
MSI (s) (B0:88) [19:03:07:452]: Running as a service.
MSI (s) (B0:88) [19:03:07:718]: Opening per-machine managed SourceList.
MSI (s) (B0:88) [19:03:07:718]: User will be allowed to modify contents of SourceList.
MSI (s) (B0:88) [19:03:07:718]: Added new source 'C:\ProgramData\Symantec\Symantec Endpoint Protection\12.1.671.4971.105\Data\Cached Installs\' with index '2'
MSI (s) (B0:14) [19:03:07:812]: Executing op: ActionStart(Name=StartServices,Description=Starting services,Template=Service: [1])
AddCacheAsInstallSource Successfully added C:\ProgramData\Symantec\Symantec Endpoint Protection\12.1.671.4971.105\Data\Cached Installs\ as source dir for {87C925D6-F6BF-4FBD-840B-53BAE2648B7B}
MSI (s) (B0:14) [19:03:07:812]: Executing op: ProgressTotal(Total=1,Type=1,ByteEquivalent=1300000)
MSI (s) (B0:14) [19:03:07:812]: Executing op: ServiceControl(,Name=SepMasterService,Action=1,Wait=1,)
MSI (s) (B0:14) [19:03:09:892]: Executing op: ActionStart(Name=ShowServiceProgress_RB,Description=Executing rollback script via service,Template=[1])
MSI (s) (B0:14) [19:03:09:892]: Executing op: CustomActionSchedule(Action=ShowServiceProgress_RB,ActionType=3329,Source=BinaryData,Target=ShowServiceProgress_RB,CustomActionData={DC2F6DF9-3CBC-4CAE-BCC2-466375BF8768};SOFTWARE\Symantec\Symantec Endpoint Protection;Executing rollback script via service;)
MSI (s) (B0:14) [19:03:09:892]: Executing op: ActionStart(Name=ShowServiceProgress,Description=Executing install script via service,Template=[1])
MSI (s) (B0:14) [19:03:09:892]: Executing op: CustomActionSchedule(Action=ShowServiceProgress,ActionType=3073,Source=BinaryData,Target=ShowServiceProgress,CustomActionData={DC2F6DF9-3CBC-4CAE-BCC2-466375BF8768};SOFTWARE\Symantec\Symantec Endpoint Protection;Executing install script via service;)
MSI (s) (B0:40) [19:03:09:892]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIB6FF.tmp, Entrypoint: ShowServiceProgress
ScriptGen: ShowServiceProgress() MSIRUNMODE_SCHEDULED
ScriptGen: ShowServiceProgress() calling WaitForSingleObject(scriptStarted) ...
ScriptGen: ShowServiceProgress() WaitForSingleObject(scriptStarted) returned WAIT_OBJECT_0
ScriptGen: ShowServiceProgress() script execution failed.
ScriptGen: ShowServiceProgress() reset script failure event.
ScriptGen: ShowServiceProgress() is returning an error (so close to the end!)
CustomAction ShowServiceProgress returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (B0:14) [19:05:02:195]: User policy value 'DisableRollback' is 0
MSI (s) (B0:14) [19:05:02:195]: Machine policy value 'DisableRollback' is 0
Action ended 19:05:02: InstallFinalize. Return value 3.

Comments 22 CommentsJump to latest comment

DayOne's picture

I don't believe a LiveUpdate installer is available for this version of SEP. I looked and didn't see the installer. Thanks for the suggestion though, I've had to use that fix in the past.

Swapnil khare's picture

Please take a backup of the registry before proceeding further.

  1. Open Regisrty Editor
  2. Browse to HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  3. Select the Expandable String Value 'AppData' and change the value to : %USERPROFILE%\AppData\Roaming
  4. Close the registry editor
  5. Reboot the computer
  6. Install SEP client again.

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

 

DayOne's picture

Unfortunately, that key is already set to %USERPROFILE%\AppData\Roaming

Rafeeq's picture

You tried all the steps in the first document, I mentioned above?

DayOne's picture

I looked through the the document. Unfortunately, none of the errors match the installation error I'm seeing. With my install error, there's no popup error or rollback; the install apears to have finished, but I get "Windows Installer installed the product. Product Name: Symantec Endpoint Protection. Product Version: 12.1.671.4971. Product Language: 1033. Manufacturer: Symantec Corporation. Installation success or error status: 1603." in the windows event log and the SEP_INST.LOG install log has an error at Line 6068 "Action ended 12:17:12: InstallFinalize. Return value 3.".

MASH1's picture

Hi,

Please confirm if you are able to install SEP 12.1 unmanaged with only "Virus and Spyware Protection".

If we are able to install SEP with basic protection then we can try below steps to install SEP with all features installed.

1) Create a Test Group

2) Edit Application and Device control policy for Test Group.

3) Click on Application Control.

4) Uncheck the option "Protect client files and registry keys" .

5) Create a new package so that the clients report to the Test Group.

6) Use the package for installation .

Please Check if the installation works.

 

- MASH

DayOne's picture

I exported an unmanaged installer with a feature set that included only the "Virus, Spyware, and Basic Download Protection" box checked. The installer failed, with what looks like the same error. Log attached.

AttachmentSize
SEP_INST-8172010.txt 3.43 MB
Rafeeq's picture

it says 

 

 Failed to set property IdcXmlPath to C:\Users\dmcfall\AppData\Local\Temp\idc.xml 
so it has to related to permissions; right click on the setup and select run as admin...UAC should be disabled.
try giving this temp folder full permision
DayOne's picture

Tried disabling UAC and running as admin, same result. I already have full permission on that temp directory.

haribhai's picture

check this out and you will be able to roll back to your previous client.

At least you will be able to test it on your test PC once your clients are back to earlier version if you had one.

https://www-secure.symantec.com/connect/forums/blu...

Shawn T.'s picture

This sounds a bit like the issue described in http://www.symantec.com/business/support/index?page=content&id=TECH164707. In most cases, you can resolve the install issue by cleaning out the previous install before installing a package with only the basic features. There is a manual uninstall document available, but I recommend calling in to create a case and requesting assistance with the uninstall/install. They will likely give you the current version of CleanWipe to help with removal.

Ajit Jha's picture

Hi

Create a x64BIT .msi package and use it onto the client machine. Install the LUSetup.exe first followed by .msi installer.

This is a manuall procedure but hope this will resolve the issue.

Regard's

Ajit Jha

Technical Consultant

ASC & STS

SolarisMaestro's picture

I would also recommend at this point to have you open a tech support case. It sounds like getting the CleanWipe utility to pull out any prior SEP bits would be a great way to go. You would then want to follow the advice of the tech support agent.

I would be curious to see what would happen if you just did an unmanaged client install right from the DVD layout. This would bypass the installation exporting from the SEPM which could be the culprit.

Once the unmanaged client is installed, you could then export the communication settings from the SEPM and do a Sylink drop in order to establish communication between the two.

If the issue persists, Tech Support can collect necessary logs and run a Standalone test on the client to see if there are any permission or other issues present.

Thank you for marking as a solution if you felt this response met your needs!

Godspeed25's picture

May sound unfamiliar, but its worth trying.

 

Uninstall the default MSI from your client computer and install the MSI that comes along with the SEP package first. Try this in one computer and let me know.

 

Above mentioned step helped me in fixing an issue with SEP 11.0.7.

Regards,

Godspeed.

SreekumarG's picture

-> Service Control  - SepMasterService
-> ShowServiceProgress returned actual error code 1603
-> Script execution failed 

Please try to give full permission for "System" account for the drive on which the SEP client is installed.

(ref. http://support.microsoft.com/kb/834484)

Uninstall all Antivirus softwares from Programs and Features

Also use the windows installer clean up tool and remove any remnants of an Antivirus software

Also, From Device Manager, Uninstall the "SRTSPX" device  and then reboot the computer.

Take backup fo the Registry and remove the following key, HKLM\SYSTEM\CurrentControlSet\Services\SRTSPX

Click Start -> All programs -> Accessories -> "right click" Command prompt -> Run as administrator

In the command prompt, type the following commands and press enter after each line

cd \

cd C:\windows\System32

regsvr32 softpub.dll
regsvr32 mssip32.dll
regsvr32  initpki.dll
regsvr32  wintrust.dll
 

Open control panel -> Windows updates

Install any important updates and recommended updates. Restart only if prompted.

Try installing SEP using the Msi, instead of exe

kathleenjoieamulong's picture

Try to uninstall the SEP 12.1 and install old version of SEP which is version 11 as unmanaged client. Delete the entry of the client is the SEPM also after the uninstallation. Then, export communication settings coming from the group which the client must be included in the SEPM. After exporting, rename the file as Sylink.xml and replace the sylink of the client in the installation path, os simply use Sylink Drop Tool. After that, run update content to update the policy. Then, create new installation package and run it in the client for the upgrade. Several reboots are required during the process. 

 

Or you can try to manually uninstall the endpoint protection. Please see reference : http://www.symantec.com/business/support/index?page=content&id=TECH161956&actp=search&viewlocale=en_US&searchid=1319613271280

Godspeed25's picture

Hi Dayone,

DIdi you try the step that I suggested.

Keeping you informed, the same step helped one of my friends....

 

Worth trying!!!

Regards,

Godspeed.

Optimus.prime's picture

Hi,

  In client installation 12.1, you have to check three different logs, first the SEP_INST , second the SIS_Inst the location is 

C:\docments and settings\all users\application data\symantec\symantec endpoint protection\12.1....\data\logs\sis_inst.log

and rollback.log on the same location

Also check the location

 

 'C:\Users\dmcfall\AppData\Local\Temp\0c58b71c-1cb5-4c08-9616-181dab353d9f\rollbackfiles.xml

Pls paste the Logs and i can check the errors in the log and fix for that...

SameerU's picture

Please install the unmanaged client package

SameerU's picture

Client installation attached