Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

SEP 12.1 Host Integrity policy

Created: 31 Oct 2012 | 15 comments

Hello,

I've created Host Integrity policy with Antivirus, Antispyware and Firewall requirements. I would like to SEP and the Firewall service to start automatically if it is turned off.
I tried commands: "C: \ Program Files \ Symantec \ Symantec Endpoint Protection \ Smc.exe-start"
"C: \ Program Files \ Symantec \ Symantec Endpoint Protection \ Smc.exe-enable-ntp" for firewall start but it does not work.
What commands should I use?

Regards

Tom

Discussion Filed Under:

Comments 15 CommentsJump to latest comment

pete_4u2002's picture

it should be

C:\Program Files\Symantec\Symantec Endpoint Protection\12.1.XXXX.XXXX.XXX\Bin\smc -start

C:\Program Files\Symantec\Symantec Endpoint Protection\12.1.XXXX.XXXX.XXX\Bin\smc -enable -ntp

tom_k's picture

Thanks but it doesn't work. In security log on client found error:

Condition The file was made​​.
Condition check "C: \ Program Files \ Symantec \ Symantec Endpoint Protection \ 12.1.1101.401.105 \ Bin \ smc-enable-ntp".
An error has occurred.
Error: file not found.

Regards

Tom

pete_4u2002's picture

well is there space after smc? (smc -start & smc -enable -ntp)

what is the SEP client version?

is it 32 bit ?

Ashish-Sharma's picture

HI,

Kindly provide SEPM version ?

Thanks In Advance

Ashish Sharma

tom_k's picture

SEPM version: 12.1.1101.401.105  (RU1 MP1)

Ashish-Sharma's picture

Hi,

Try this

C:\Program Files\Symantec\Symantec Endpoint Protection\12.1.1101.401.105\Bin\smc -start
C:\Program Files\Symantec\Symantec Endpoint Protection\12.1.1101.401.105\Bin\smc -Enable -NTP

Provide Space

Smc -Enable -Ntp

Thanks In Advance

Ashish Sharma

tom_k's picture

Of course, I used the space. Spaces are removed when paste the log on the forum. :)
Unfortunately, the same error ...

Ashish-Sharma's picture

HI,

Do you have try 64 bit os or 32 bit ?

If Os 64 bit try this command

C:\Program Files (x86)\Symantec\Symantec Endpoint Protection\12.1.1101.401.105\Bin\smc -Enable -NTP

Thanks In Advance

Ashish Sharma

tom_k's picture

32-bit. Also tried double quotes but no change.

Ashish-Sharma's picture

HI Tom,

Kindly check

"C:\Program Files\Symantec\Symantec Endpoint Protection\12.1.671.4971.105\Bin\Smc.exe" -start

"C:\Program Files\Symantec\Symantec Endpoint Protection\12.1.671.4971.105\Bin\Smc.exe" -Enable -NTP

Thanks In Advance

Ashish Sharma

tom_k's picture

Thanks. It works if I disable SEP by right-clicking the SEP icon and choose "Turn-off Symantec Endpoint Protection".
Is this rule should start the program if the SEP is disabled by "smc-stop" command?

Regards

Tom

Ashish-Sharma's picture

Hi,

Your problem ae solved or not ?

Thanks In Advance

Ashish Sharma

tom_k's picture

Not quite because SEP does not automatically start if I disable it by "smc -stop" command.

Ashish-Sharma's picture

HI,

Try to disable tamper protection after check this command.

Thanks In Advance

Ashish Sharma

tom_k's picture

I disabled tamper protection and also turned off UAC. Unfortunately SEP services still not started automatically.