Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

SEP Client can't contact SEPM

Created: 29 Jan 2013 | 7 comments

Hi all,

I'm using SEP 12.1 small business edition, some of my clients can't connect to SEPM.

I already tried to troubleshoot from the client by clicking HELP->troubleshooting->connection status->connect now and I got error 12031. I check the log and it says unknown error. I search on the internet and have solution, but it is for 11.x version, which modify the bandwidth limit on IIS.

Some of the client can connect, but after a few days it lost the connection to server and I need to connect to server manually by following the troubleshooting step. How many clients does SEPM 12.1 can manage? Anyone ever meet this error before?

 

Thanks

Comments 7 CommentsJump to latest comment

MASH1's picture

Hi Neaja,

 

You would need to replace Sylink file and check if clients can communicate to SEPM.

Sylink file is the communication files used by SEP clients to find SEPM and connect to it.

Try replacing sylink fileon one machine and check if connects back to SEPM.

Use the below link for the process to replace the sylink file.

http://www.symantec.com/business/support/index?pag...

 

- MASH

- MASH

SebastianZ's picture

How is your client-server communication configured - does it go over SSL?

Try replacing sylink as mentioned in the post above - if this does not work can you post sylink.log from that client - it should show more detailled error that only error code:

http://www.symantec.com/docs/TECH104758

 

Then in the sylink look if in addition to this error:

<ParseErrorCode:>12031=>Unknown error code.

..if you will find this as well:

<ParseErrorCode:>12057=>Revocation of the SSL certificate failed.

 

If you can find the second error as well the solution would be to  change "EnablePMTUDiscovery" on the OS from "1" to "0" - http://technet.microsoft.com/en-us/library/cc95753...

Ashish-Sharma's picture

HI,

Try to export new Sylink.xml and replace to one or two sep client

Thanks In Advance

Ashish Sharma

 

 

Chetan Savade's picture

Hi,

Symantec Endpoint Protection Small Business Edition incorporates many of the features from the enterprise edition. It is designed for small-to-medium businesses with up to 250 clients. Previous version used to support only 100 computers.

Check this article: https://www-secure.symantec.com/connect/articles/w...

What troubleshooting steps you do follow to connect to server?

Are you using OS image to deploy new clients in the network?

 

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

neaja's picture

Hi all, thank for your reply,

I havent try to import the sylink.xml, but I already tried uninstalled and install again using the latest package from SEPM. SOme of the clients that can reach the server using the same package. yes, all the client can reach the server both IP and DNS.

I will give you update after I replace the sylink.xml.

Thanks!

neaja's picture

Hi all,

I already tried to replace the sylink.xml, some of the client works, but some aren't.

Here is the sylink log

1/31 09:57:03.184 [2356] <SendRegistrationRequest:>http://censored:8014
01/31 09:57:03.184 [2356] 9:57:3=>Send HTTP REQUEST
01/31 09:57:03.216 [2356] Throw Internet Exception, Error Code=12031;AH: failed to write internet file
01/31 09:57:03.216 [2356] CInternetException: <SendRegistrationRequest:>: The connection with the server was reset

 

Thanks!

SebastianZ's picture

Take the back up of the registry and delete the following  registry values

*HKEY_USER\.DEFAULT\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\DefaultConnectionSettings
 
*HKEY_USER\.DEFAULT\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\SavedLegacySettings

After rebooting the machine replace the sylink again.