Video Screencast Help

SEP Installation via SCCM Task Sequence

Created: 09 Mar 2010 • Updated: 21 May 2010 | 11 comments
This issue has been solved. See solution.

Hi Everybody,

Apologies if this is in the wrong group. I am trying to install SEP as part of an SCCM task sequence during operating system deployment. I have got both a single exe file and the extracted folder with the msi file.

The setup exe, is a completley silent install with my companies sylink included. I have built a package and program and avertised this to a couple of machines and it has installed fine - fully functional and connecting to my companies update server. However, if I add this program to as part of a task sequence during the deployment process, the installation fails and returns an exit code of 1.

I have written a cmd file with the following:

setup.exe /wait
set %errorlevel%=0

This allows the task sequence to complete without any errors, however it does not actually install - no folders of files created etc...

Does anyone have any experience with deploying endpoint protection as part of an SCCM task sequence?

Any help would really realy be appreciated!

Many thanks,

Ali

Comments 11 CommentsJump to latest comment

Rick Bywalski's picture

I never tried this but I have few thoughts.  Things I have done is an SMS 2003 push we are in the middle of our coversion to SCCM and I do have it working with Task sequence in the MDT2010 for my Windows 7 image build.  Check and see where your log files are writing at.  If they are going to a location that does not exist it will fail like that.   What OS are you pushing to as well?

alirankine's picture

Hi Rick. I have taken a look and the logs are stored in %ProgramFiles%\SMS_CCM\Logs folder on the sccm server. I have succesfully installed other application as part of the task sequence and all the logs have been succesful.

I am trying to push both Windows 7 and XP SP3 and have had the same experience with both OS's. (I am using SCCM 2007 R2).

Thanks again!

Rafeeq's picture

can you check in temp folder
if you have any logs files related to sep
start-run-%temp%
look for SEP_INST.log 

alirankine's picture

Hi Rafeeq, I will kick of a build now which should be done in an hour (ish) and will let you know about the logs files.

alirankine's picture

Hi Rafeeq, I have built a PC and there was a log file created. I will attach it to this post.

AttachmentSize
SEP_INST.doc 95.5 KB
Rafeeq's picture
 
it says
 
Symantec Endpoint Protection has detected that there are pending system changes that require a reboot.  Please reboot the system and rerun the installation.
Action ended 10:57:37: LaunchConditions. Return value 3
 
 
follow this document
 

http://service1.symantec.com/SUPPORT/ent-security....

rename reboot value and delete pending as per the doc

alirankine's picture

Ok thanks, the link you sent me doesn't seem to work. Gives me a symantec error page.

Thanks Again!

alirankine's picture

Perfect thanks! I am not sure how I would be able to include this solution as part of a task sequence during the build process. I have however, told the system to restart before it installs SEP. So hopefully it should now work.

I will let you know how it goes!

Rafeeq's picture

it does not happen on all the boxes
if you have done any windows update or any software waiting for reboot then sep wont get installed.
Make sure that you dont have such stuffs, try this document  on those who fail... 

alirankine's picture

After a lot of painful testing, I have finally managed to get SEP to install as part of an SCCM task sequence. The reason it would not install previousley was due to a pending restart from other software that had installed during the task sequence.

I tried moving the SEP installation to various stages in the task sequence and eventually found the right place to put it so that it does not cause the same error (pending restart), on other applications. It did take a while to work it out, and I have ahd to add another system restart as part of the task sequence. However, it does now seamlessly install to 7 different models of PC, all with different software (using variables) in one task sequence.

Just to let you know if anyone else has the same problem, I inatalled SEP using the first method i mentioned in the first post (self contained .exe file and created a .cmd file). Not sure if I actually need the /wait and set errorlevel command, but I dare not take them out as it works exactly as I want!

Hope this helps - and thank you to those who helped me work out the issue in the first place.

SOLUTION