Video Screencast Help

SEP Manager service will not start

Created: 20 Oct 2012 | 17 comments

Last night I found out that the sem5.log had grown so huge that it caused the server to run out of space. So I followed instructions in this article -> http://www.symantec.com/docs/TECH178718 but it didn't help (even tried restarting the system). So the next thing I looked at was the log file catalina.out under C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat\logs and found the following lines

"Missing property: scm.db.datasource" and "Server is not configured correctly, please run Server Configuration Assistant!"

So I went to run the configuration wizard and I got an error that port 2638 was in use. I found out that there were other SQL Anywhere instances running on port 2638, so I stopped those services and ran the configuration wizard again. This time when it came to the database, I choose to change the port from 2638 to 2639 to avoid conflicts. It prompted me to overwrite the sem5.db file which I did.

After doing all of the above I restarted the server and it is still not working. I am getting the below listed error and I am searching for direction at this time. I have tried restarting the service, which starts and ends within a couple of seconds.

Error 4096 in event viewer "The Java Virtual Machine has exited with a code of -1, the service is being stopped"

Also a apache related error is being logged in the event viewer.

Error 3299 "The apache service named reported the following error: httpd.exe Could not reliably determine the servers fully qualified domain name, using 10.10.10.1 for ServerName"

I have also added "scm.log.loglevel=fine" in the conf.properties file in C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat\etc folder and upon doing this the following was logged in C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat\logs\sepm_64482152.log file.

"Thread-1: [com.creamtec.ajaxswing.JVMProcess$1] Health check failed, exiting."

I have updated java on the server as well. I am not sure where the issue is but any help would be grealy appreciated.

Thanks

System information: SEP 12.1 on server 2008 R2

Comments 17 CommentsJump to latest comment

greg12's picture

See this article to change the port of the embedded database:

How to use a custom port for the Embedded database on Symantec Endpoint Protection 12.1

http://www.symantec.com/docs/TECH157461

BTW, you will probably need the database password (see step 10), which is the initial admin password that was defined during the SEPM installation.

oho-oakland's picture

As per the article, the only place that the new port number wasn't updated was in the Root.xml file under tomcat settings. I updated that and restarted the service but it didn't make a difference, service starts and stops right away.

Seyad's picture

Follow the steps below.

1) If started, stop 'Symantec Embedded Database' Service.

2) Open task manager and terminate 'dbsrv11.exe'.

3) If exist, delete sem5.log

4) Make a copy of the 'db' and 'server private key backup' folders from SEPM installation folder (c:\program files\symantec\symantec endpoint protection manager\" to a backup folder.

Open conf.properties and check how many lines you have in there and let me know that. Will give you further steps based on that. Please do not run Management server configuration wizard at this time. This might lead to the loss of data in the database. Also, revert the changes made to change the port number 2638.

 

Cheers.

oho-oakland's picture

1. Stopped service

2. no such process was running

3. deleted sem5.log

4. backup made

5. content from conf.properties file is below (I have deleted some values after the = sign):

6. As soon as I hear back from you on next steps, I will revert the port number changes and go from there.

-----------------------------------------

 

#Server Configuration Properties (conf.properties file)
#Sat Oct 20 14:35:34 EDT 2012
scm.install.has.SNAC.license=0
scm.webserver.http.port=8014
scm.companysize=
scm.server.id=
scm.webservices.port=8444
scm.license.producttype=SEPE
scm.securityalertnotifytask.notification.interval=1
scm.agent.root=C\:\\Program Files (x86)\\Symantec\\Symantec Endpoint Protection Manager\\data
scm.console.reporting.https.port=8445
scm.http.port=9090
scm.db.client.bin=C\:\\Program Files (x86)\\Symantec\\Symantec Endpoint Protection Manager\\ASA\\win32
scm.server.name=
scm.shutdown.port=8765
scm.agent.kcs=
scm.site.name=
scm.server.port=8443
scm.agent.groupcreation=false
scm.log.loglevel=fine
 
----------------------------------------------
 
Thanks
Seyad's picture

Conf.properties looks good. Running Management server configuration wizard at this time should be fine.

Start 'Symantec Embedded Database' Service and run the Management server configuration wizard and let me know if you still run in to errors related to port numbers.

oho-oakland's picture

Are you saying that even though I have other programs using SQL Anywhere I should leave the port number defaulted to 2638 when I run the management wizard?

Seyad's picture

If you were able to run the SEPM before the sem5.log issue happened, then you shoud be able to run this now also. SQL anywhere is nothing but dbsrv11.exe (unless there is another version of dbsrv running). You confirmed that there were no dbsrv11.exe after stopping the database service.

oho-oakland's picture

I have reverted all the port numbers back to 2638. I go into the configuration wizard and after the database selection option (embedded or SQL) the next screen has the port number defaulted to 2639 and it is grayed out so I cannot change it. I have tried rebooting the server and double checked all the locations mentioned in that article but it is still defaulting to 2639. Now what?

Seyad's picture

This port used to access the database. We are good as long as the we are able to access the database. Make sure that the Symantec Embedded database service is started and continue running the Management server configuration wizard with the port 2639.

oho-oakland's picture

When I continue with port 2639 I get an error that says the following: "The server port you chose is not used by the database server. You must choose the port that the embedded database server uses". It does not allow me to change the port in the configuration wizard. Can I manually change the port number in the backup file that the wizard reads at the beginning?

Seyad's picture

Run the configuration wizard without using a recovery file.

oho-oakland's picture

No luck, I still have the same errors popping up in Event viewer and the service stops almost as soon as it starts. Error 3299 Apache, could not determine FQDN and Error 4096, JVM exited with code 1.

Seyad's picture

A SEP support tool log would be helpful to troubleshoot further. Please open a support ticket with Enterprise support to work further on this.

Ashish-Sharma's picture

Hi,

Try to repaire sepm add/remove program.

Symantec Endpoint Protection Manager service stops with a Java -1 error in the event log when using a remote SQL server

http://www.symantec.com/business/support/index?page=content&id=TECH102693&locale=en_US

Check this thread

https://www-secure.symantec.com/connect/forums/cannot-start-sepm-java-virtual-machine-error-4096

Thanks In Advance

Ashish Sharma

 

 

A. Wesker's picture

Hi Oho,

 

Sorry but it's pretty obvious that your conf.properties is not good.

Probably cause of the disk space issue and a repair or when you ran the Server Configuration Wizard the information has gone. Known issue especially after a disk space issue.

 

Your conf.properties file below.

#Server Configuration Properties (conf.properties file)
#Sat Oct 20 14:35:34 EDT 2012
scm.install.has.SNAC.license=0
scm.webserver.http.port=8014
scm.companysize=
scm.server.id=
scm.webservices.port=8444
scm.license.producttype=SEPE
scm.securityalertnotifytask.notification.interval=1
scm.agent.root=C\:\\Program Files (x86)\\Symantec\\Symantec Endpoint Protection Manager\\data
scm.console.reporting.https.port=8445
scm.http.port=9090
scm.db.client.bin=C\:\\Program Files (x86)\\Symantec\\Symantec Endpoint Protection Manager\\ASA\\win32
scm.server.name=
scm.shutdown.port=8765
scm.agent.kcs=
scm.site.name=
scm.server.port=8443
scm.agent.groupcreation=false
scm.log.loglevel=fine
 
 
The missing line on your conf.properties file is scm.db.datasource=jdbc/metadatabase
 
Follow the instructions of this article below and see if it works.
 
 
 
If it's still doesn't work and you have a backup, perform a Disaster Recovery.
 
 
 
Then once your SEPM works good, migrate to SEPM Small Business Edition RU1 MP1 then it will your issue with the sem5.log file not getting automatically truncated.
 
I provided you the exact FIX ID about that below.
 
Small Business Edition SEPM database transaction log does not truncate
Fix ID: 2660649
Symptom: The database transaction log on the SEPM Small Business Edition (SBE) server does not truncate. This may consume all of the available space on the server's hard drive.
Solution: The server was modified to prevent a build-up of the database transaction log.
 
Link to the full release notes of SEP 12.1 RU1 MP1 => http://www.symantec.com/business/support/index?page=content&id=TECH187656
 
 
Kind Regards,
 
A. Wesker
 
oho-oakland's picture

Before I saw your post, I ended up uninstalling SEP Manager and reinstalling it and redeploying the clients again, so there really is no way for me to check for sure the solution you are proposing.

Ashish-Sharma's picture

hi,

Did you try to Repair SEPM server ?

Good to hear Your Problem has been solved. :)

Thanks In Advance

Ashish Sharma