Video Screencast Help

SEPIC - Updating altiris agent settings once agent is deployed

Created: 01 Mar 2011 • Updated: 01 Mar 2011 | 8 comments
This issue has been solved. See solution.

Hello,

We have deployed a number of altiris agents with one set of settings to our client computers. Our situation has now changed and we need to deploy a different set of altiris agent rules, namely the bandwidth throttling settings.

Can anyone tell me if its possible to update the client settings without the need to deploy the entire agent again? does the altiris client look for new configuration at its heartbeat interval?

Many thanks.

Comments 8 CommentsJump to latest comment

Cesar_echeverria's picture

yeah right, only to change the settings of the agent

go

Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Symantec Management Agent Settings - Targeted

Make the necessary changes and Save Changes.

Cesar Echeverria Castillo

Consultant Engineer

InterLAN Ltda, Medellin, Colombia

P.S.: If this works please let the community knows about it.

Aeropars's picture

Hello,

I'm aware of how to change the settings but my question is whether the agent needs to be installed again or will the agent just download a configuration? If the latter, will it do this automatically?

Cesar_echeverria's picture

The agents on the next application configuration changes take. without having to reinstall.

changes are applied automatically

Cesar Echeverria Castillo

Consultant Engineer

InterLAN Ltda, Medellin, Colombia

P.S.: If this works please let the community knows about it.

mclemson's picture

The changes you assign here will be detected by clients when they contact the Notification Server to check for an updated configuration.  By default, this happens every 60 minutes.  If it finds that the configuration it holds is different than the one being offered by the Notification Server, it will download the updated configuration and begin using it.

Reinstalling the agent is necessary only if the agent has some sort of problem (error message, misbehaving, etc).  An installation procedure also happens when upgrading to a new agent, such as after updating your Notification Server to a new version.  If your NS is SP5 and your clients SP4, for example, you should enable an upgrade policy on your NS so that your clients will run the upgrade installation procedure.

Does this help?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

SOLUTION
Aeropars's picture

Thanks for the reply. Like I said in my first post, we're using the SEPIC version of notification server however I understand the principles are the same.

Just so confirm I'm understanding this correctly here's what I'll do:

  • We have a number of clients already installed with a configuration and agent.
  • I click Settings > Agent / Plug ins > Altiris Agent
  • Click on Altiris Agent Settings - Targeted
  • On the 'Downloads' tab I change the throttling periods to suit.

By doing this all clients should then download this new configration without the need to reinstalling the agent.

Is this correct?

Thanks for your help so far.

mclemson's picture

Yes.  You can confirm that the agent has updated its configuration by right-clicking on the agent in the system tray and clicking Symantec Management Agent Settings.  Under Configuration, you'll see the last time the configuration was changed as well as the interval for requesting updates.  You can click Update here to force an update of the configuration.  This is helpful in providing immediate effect for agent policies as well as any other policy you might create, especially helpful when testing policies for intended behavior before release.  Because, really, who would want to wait an hour while testing?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Cesar_echeverria's picture

That's right, it works

Cesar Echeverria Castillo

Consultant Engineer

InterLAN Ltda, Medellin, Colombia

P.S.: If this works please let the community knows about it.