Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SEPM automatic client upgrade pushes wrong version to some servers?

Created: 12 Jul 2010 • Updated: 23 Aug 2010 | 8 comments
This issue has been solved. See solution.

I've added both 32 and 64-bit SEP packages, version 11.0.6005.562, to a group of Clients in SEPM, and set the upgrade window to 2-6 AM over 3 days.  It has been the full 3 days now, and about 80% of the computers report having the new client.

However, a few servers still note having client version 11.0.5002.333.  Upon further inspection, opening C:\Program Files\Symantec\Symantec Endpoint Protection\Download on some of these servers reveals that they received a file called "PKGb6388acd7a9fcafe517ffac8165a2a4411.0.5002.3331", last modified at 5:59AM during a day in the upgrade window.  Could SEPM be pushing the wrong version to these clients?  Or is there another problem that needs fixing to get SEPM to properly update these clients?

Comments 8 CommentsJump to latest comment

sandra.g's picture

So the servers and the other machines are all in the same client group, the one with the RU6a packages assigned?  Is the RU5 package still somehow appearing in the "Install packages" tab?

One thing I have noticed is that client install packages are not inherited.  The install package must be assigned to each group you want to upgrade.  Let us know if this is the case.

sandra

Symantec, Senior Information Developer
Enterprise Security, Mobility, and Management - Endpoint Protection

Don't forget to mark your thread as 'solved' with the answer that best helps you!

Crimson Zen's picture

There is one group called "Servers," and the Install Packages tab only lists the 32-bit and 64-bit packages for RU6a, just those two entries.  The packages were directly assigned to the "Servers" group.

There are other groups in the domain, but I'm only concerned with updating the members of "Servers."

Crimson Zen's picture

Looks like one of the servers that downloaded an old package is now reporting the up-to-date version of SEPM, but some are still hanging back.  Most notably are two servers with about ~500MB of space left, which periodically drop in space (presumably expanding the installer), and then revert to the old level of disk space.  Maybe the installer is failing for some reason, and retrying periodically?

WHairstonLOI's picture

Could be that 500MB of disk space simply isn't enough to expand and install everything. On some of my servers, I've seen the updates fail due to insufficient space - I usually have to keep over 1GB minimum to ensure the updates have enough working room.

SOLUTION
Crimson Zen's picture

There's enough free space on most of the 6 servers that have so far failed to auto-upgrade.  One has at least 3 GB free, and is still failing.  On the other servers, the disk space doesn't drop to 0, but to maybe 200MB~ left before reverting.  Though, these could be unrelated problems.  I'll see if I can free up some space.

AravindKM's picture

Some time the client systems needs to be restarted for getting it upgraded......

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

AravindKM's picture

Some times the client systems needs to be restarted for getting it upgraded......

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Crimson Zen's picture

Turns out, one of the terminal servers was unable to update - maybe because of the change user /install VS /execute setting?    On the others, it looks like it needs about 700MB~ to properly extract and update.  Thanks for the help.