Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SEPM database question

Created: 25 Jun 2012 • Updated: 26 Jun 2012 | 16 comments
This issue has been solved. See solution.

Hey,

Just looking for some information on the SEPM database. Im running SEPM 12.1.1000.157 and my database is local on version 11.0.1.2472, called Sem5. I was just inquiring about the reason why my database version is 11.0.1 however my Console is 12.1? Any information regaurding the methodology behind the database would be great.

Thanks!

Comments 16 CommentsJump to latest comment

pete_4u2002's picture

which log file are you seeing this value?

can you post the screenshot if possible?

Mohannad Qunbar's picture

yea heres a screnshot of the properties in the console.

Database.png
pete_4u2002's picture

can you run the upgrade.bat from tomcat\bin folder of SEPM?

HotRob's picture

In my case, that file doesn't exist (in that location at least).

pete_4u2002's picture

can you click on SEPM --> home page and click on about and post a screen shot?

HotRob's picture

From the 'About' screen:

From the Server database properties:

pete_4u2002's picture

this is normal as the SQL version is 2008 it will show 10.X.

to check the sem5 database version you need to check this field

pete_4u2002's picture

this is correct as it is showing sybase database version.

P_K_'s picture

Ideally your database version should say, but is this a upgrade??

Product Release Format Version Database Version
SEP 11 RTM 11.0.0.1 11.0.0.1
SEP 11 MR1 11.0.0.3 11.0.0.3
SEP 11 MR2 11.0.0.4 11.0.0.4
SEP 11 MR3 11.0.1.0 11.0.1.0
SEP 11 RU4 MP1 11.0.2.1 11.0.2.1
SEP 11 MR4 MP2 11.0.2.2 11.0.2.2
SEP 11 RU5 11.0.3.0 11.0.3.0
SEP 11 RU6 11.0.6.0 11.0.6.0
SEP 11 RU6 MP1 11.0.6.1 11.0.6.1
SEP 11 RU6 MP2 11.0.6.2 11.0.6.2
SEP 12.1 RTM 12.1.0.3 12.1.0.3
SEP 12.1 RU1 12.1.1.0 12.1.1.0

In the SEPM's Management Server Upgrade Wizard, the initial version seen on screen is not a detection of the version of SEP/SEPM that was previously on the server. It indicates the version of the database.

So, it is correct for a SEP 11 MR4 upgrade install, for instance, to display "Upgrade Server from 11.0.1.0" even though it was upgrading from SEP 11 MR3.

The upgrade.log will also record database version: "Config schema format is upgraded from: 11.0.1.0."

MCT MCSE-2012 Symantec Technical Specialist (SCTS)

HotRob's picture

Hi,

I just did a brand new install of 12.1 RU1_MP1 and the database version reads 10.00.5500 and thats using an SQL 2008 database?

As the above table indicates i would have thought a brand new install would have the latest database version or is this different again for using a SQL backend?

Cheers,

Rob 

P_K_'s picture

That's strange, I have not come acroos anything like that before.

MCT MCSE-2012 Symantec Technical Specialist (SCTS)

Mithun Sanghavi's picture

Hello,

In your case, I would suggest you to perform a Disaster Recovery Steps for SEPM 12.1, check this Article:

Symantec Endpoint Protection 12.1: Best Practices for Disaster Recovery with the Symantec Endpoint Protection Manager

http://www.symantec.com/docs/TECH160736

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Mohannad Qunbar's picture

Heres a screen shot of my about page on the welcome screen. Just wondering if this is normal, because my database version (above) is showing version 11.0.1.2472 ?

thanks,

about sepm.jpg
greg12's picture

Symantec uses a Sybase product for its embedded database. This product (SQL Anywhere) has in your  case the Sybase version number 11.0.1. This has nothing to do with the SEP version number or the database schema version number for SEPM.

Have a look here: http://www.sybase.de/detail?id=1002288

With SQL Server, it's the same: SQL Server 10 is the version number of SQL Server 2008. See here:

http://en.wikipedia.org/wiki/Microsoft_SQL_Server

HTH

#EDIT: In the Windows Task Manager, you can see the database process as dbsrv11.exe. In SEP 11, it was dbsrv9.exe because Symantec used Sybase SQL Anywhere v9 at that time.

SOLUTION