Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

SEPM, How to recover when you missed one patch installation

Created: 02 Mar 2009 • Updated: 21 May 2010 | 4 comments

Hi all,
recently I was running SEPM MR3, then downloaded MR4 MP1 and upgraded. It was my fault and SEPM stopped running.
I needed to run MR4 first! bump!

Now, we upgraded our licence and I had no access to MR3 installation CD and I was in a hurry, so this is what I have done
to recover the server

1. you will need a recent backup of SEPM
2. Follow this instructions:
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007082112135948

2.1 I have done this:
Install SEPM, use any connect and DB password(because you have a backup of the DB).
Login in the console a do the JKS step
Restart SEPM
Stop SEPM
Now do the DB Restore, you will end up with a MR3 DB in a MR4 Installation
3. Don start SEPM yet, just run the MR4 setup again
4. Choose Repair and at the end the DB Upgrade tool will appear, this will update your MR3 DB to MR4
5. Run the Management Server Configuration Wizard tool
6. you're done!

I hope Symantec can warn you that a previous version is required. I say a warning in case you need to do some strange install. A warning like the "you don't have 1024MB of RAM" message will help.

HTH
Oliver

Discussion Filed Under:

Comments 4 CommentsJump to latest comment

Paul Murgatroyd's picture

I think you've just had an unfortunate upgrade issue.. we fully support migrating SEPM MR3 to MR4 MP1, its the client only patches that need MR4 first (yes, I know what the release notes say).

 

Good steps though, all I will add is that there is no need to run the setup again, just browse into the SEPM folders and find upgrade.bat and run it.  I think its either in bin or tomcat\bin  :smileyhappy:

 

 

Paul Murgatroyd
Principal Product Manager, Symantec Endpoint Protection
Endpoint twitter feed: http://twitter.com/symc_endpoint

oliversl's picture

Hi Paul,
yes, I have had a DB Upgrade failure when upgrading from MR3 to MR4 MP1. I loss all of my 2008 logs indeed :(

https://forums2.symantec.com/syment/board/message?board.id=endpoint_protection11&thread.id=26592

Thanks for the dbugrade tip, I was hoping such command existed and now I know :)

Regards,
Oliver

http://tinymailto.com/oliversl <-- my email after a captcha

oliversl's picture

Hi Paul,
I solved the problem, I unzipped the files in Mac OSX Leopard and it created some hidden files.

Then the installer blindly copied those hidden files to the tomcat/packages directory and the dbupgrade.cmd command tryied to add thos hidden files as they were actual SEP client packages

I deleted the files starting with ._ and the problem was solved

HTH
Oliver

http://tinymailto.com/oliversl <-- my email after a captcha

Viachaslau Kabak's picture

about SEPM Upgrade - you need to test the upgrade first

i upgraded 22 SEPMs successfully - only 1 issue on 1 SEPM - client didn't update information about definitions

client are up-to-date, but in the console they are out-of-date

resolvation: removed and added OU syncronization groups - everything is fine after clients connected to SEPM