Video Screencast Help

SEPM Live update failing

Created: 26 Mar 2012 | 9 comments

Hi,

 

We have SEPM version 12.1 installed on a 2008 Server Ent SP2. We have this issue where most of the clients go out of date after a while. On checking, found that the Live update on the server keeps failing. We contacted Symantec support and have been working with them for more than a month now with no solution is sight. Symantec support keeps juggling between LU reinstall and rebooting SEPM server. After reinstall, LU seems to work fine for some days.

The current Defs on the SEPM are of 22/03/2012. Here is the most recent errors when we tried to run LU manually from the manager -

LiveUpdate encountered one or more errors Return code = 4

Suggestions are welcome.

 

Thanks,

Voltadm

Comments 9 CommentsJump to latest comment

pete_4u2002's picture

check this link to troubleshoot the issue

Error: LiveUpdate encountered one or more errors. Return code = 4" in LiveUpdate status in Symantec Endpoint Protection Manager

http://www.symantec.com/business/support/index?page=content&id=TECH103112

Simpson Homer's picture

Uninstall Liveupdate

Re-register Liveupdater with SEPM by following the procedure

 

* Open a command prompt window, then browse to:

For 32 bit Operating System 
C:\Program Files\Symantec\Symantec Endpoint Protection Manager\bin

and for the 64 bit

C:\Program Files(X86)\Symantec\Symantec Endpoint Protection Manager\bin

* Execute lucatalog -cleanup

 

Reinstall Liveupdate

 

* Open a command prompt window, then browse to:

For 32 bit Operating System 
C:\Program Files\Symantec\Symantec Endpoint Protection Manager\bin

and for the 64 bit

C:\Program Files(X86)\Symantec\Symantec Endpoint Protection Manager\bin

 

 Execute lucatalog -forcedupdate
* Run LiveUpdate from the console or execute LUALL.exe to verify that there are no errors.

Mithun Sanghavi's picture

Hello,

LiveUpdate encountered one or more errors Return code = 4 is a Generic Error.

To understand more about issue, could you please upload the Log.liveupdate from your SEPM server?

Are you using any Proxy?

Did you try disabling the Windows Firewall on the machine and checked ?

 

 

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

DanC@BYU's picture

We upgraded our infrastructure to 12.1 a few weeks ago and have been seeing similar issues ever since. I get SEPM Alerts claiming LiveUpdate failed, however it looks like LiveUpdate retries and succeeds, from the Servers | Site | Show LiveUpdate downloads, we do have the most current revision with all the content signatures. Looking through the sesmlu log does show failures, but also shows "SesmLu Successfully notified sever of up-to-date content" I think the SEPM server is getting good content from LiveUpdate. I would like to know why we are getting the failures. It is an intermittent issue, though it is still somewhat unsettling to have these unexplained failures.

Mick2009's picture

Hi Voltadm,

Does that SEPm go to the Internet or to an interenal LiveUpdate source for its updates?

Also: when uninstalling and reinstalling LiveUpdate, are you using the correct client for SEP 12.1?  (version 3.3.1.23- nothing earlier!)

Windows LiveUpdate Client for Use with Symantec Endpoint Protection Manager 12.1
Article: TECH181305   |  Created: 2012-02-13   |  Updated: 2012-03-21   | 
Article URL http://www.symantec.com/docs/TECH181305 
 

With thanks and best regards,

Mick

Sonday's picture

Hi,

Uninstall liveupdate

Reinstall & register liveupdate thru sepm.

Follow this article..

http://www.symantec.com/business/support/index?pag...

 

One more is there to try if the issue was not resolve.

Follow the steps which are marked solution

https://www-secure.symantec.com/connect/forums/liv...

sunnyc_up's picture

hi,

Are you using the open internet access on SEPM server and confiugred "DO NOT USE PROXY" in live update settings ?

 

Regard

Sunny Chauhan

Sandeep Joshi's picture

Check the Symantec Liveupdate icon on the control panel.

On Http tab make sure first and the third radio button is selected if you are not using Proxy ie:

I want to use my internet options HTTP settings

I dont want to use proxy server for HTTP.

 

If this does not resolve the issue.

Please upload the log.liveupdate from the following location .

C:\Program Files\Symantec\LiveUpdate

 

STS Symantec Endpoint Protection

Voltadm's picture

Hi,

After working with Symantec support for more than 2 months and uninstalling and reinstalling the SEP manager (using the old database) and sending the database to them so they can check integrity and fix corruption, we reached no where.

Had also tried uninstalling and reinstalling-re-registering live updater on sepm with Symantec support. We donot use proxy and firewall was disabled on the server.

Ultimately we had to install a new server altogether and migrate the clients to the new SEPM server.

Sorry about the late respnse...

 

Thanks for all the replies !!

 

Regards,

Voltadm