Video Screencast Help

SEPM mail not working after migrating to new server

Created: 09 Apr 2014 • Updated: 09 Apr 2014 | 9 comments
This issue has been solved. See solution.

I migrated the SEPM from old the server to a new server.

I kept all settings and imported the database from the old server.

I didn't modify the email settings. Our smtp server needs no authentification.

On the new server, SEPM is not sending any mail with the exact same mail settings.

If I try to send a test mail from the mail server setting via SEPM console, following error appears:

email.JPG

If we try to send a mail from the server via telnet, it's working fine without smtp authentification.

I already tried to repair the installation via SEPM setup. (suggestion from https://www-secure.symantec.com/connect/forums/sepm-console-not-sending-auto-email-notification)

SEPM version 12.1.4

Operating system Windows 7

Operating Systems:

Comments 9 CommentsJump to latest comment

Rafeeq's picture

did you add it now ? or it was migrated from previous versions? are you able to reach your mail server?

enable the advanced troubleshooting and enable mail troubleshoot to 1, it might point out to the issue

How to debug the Symantec Endpoint Protection Manager

http://www.symantec.com/business/support/index?pag...

James007's picture

Are you able telnet port 25 ?

How to Configure E-mail Alerts in the Symantec Endpoint Protection Manager (SEPM)

http://www.symantec.com/docs/TECH105865

BREL's picture

telnet on port 25 is working and I can send mails via telnet without smtp authentification

BREL's picture

the mail settings were already configured on the old server and was working fine.

On the old server we had the same version 12.1.4. (we moved from windows xp to windows 7 and kept the same IP address. The old server is offline now to avoid a ip address conflict).

I am able to reach the smtp server from our SEPM server via telnet.

Rafeeq's picture

Enable the logging an attach the mail troubleshoot files

BREL's picture

I set the loglevel to FINEST an collected the logfiles.

Which of these logfiles do you need?

I can see some error in the scm-ui-*..err logfiles

Line 186: 09.04.2014 13:30:21  STDERR: com.sygate.scm.util.mail.EmailException: javax.mail.MessagingException: Could not connect to SMTP host: 192.168.2.10, port: 25;
    Line 186: 09.04.2014 13:30:21  STDERR: com.sygate.scm.util.mail.EmailException: javax.mail.MessagingException: Could not connect to SMTP host: 192.168.2.10, port: 25;
    Line 189: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.sendMessage(Email.java:428)
    Line 189: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.sendMessage(Email.java:428)
    Line 189: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.sendMessage(Email.java:428)
    Line 190: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.send(Email.java:334)
    Line 190: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.send(Email.java:334)
    Line 190: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.send(Email.java:334)
    Line 191: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.send(Email.java:300)
    Line 191: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.send(Email.java:300)
    Line 191: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.send(Email.java:300)
    Line 192: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.TestEmailSender$1.construct(TestEmailSender.java:76)
    Line 192: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.TestEmailSender$1.construct(TestEmailSender.java:76)
    Line 192: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.TestEmailSender$1.construct(TestEmailSender.java:76)
    Line 195: 09.04.2014 13:30:21  STDERR: Caused by: javax.mail.MessagingException: Could not connect to SMTP host: 192.168.2.10, port: 25;
    Line 198: 09.04.2014 13:30:21  STDERR:     at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1391)
    Line 199: 09.04.2014 13:30:21  STDERR:     at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:412)
    Line 200: 09.04.2014 13:30:21  STDERR:     at javax.mail.Service.connect(Service.java:288)
    Line 201: 09.04.2014 13:30:21  STDERR:     at javax.mail.Service.connect(Service.java:169)
    Line 202: 09.04.2014 13:30:21  STDERR:     at javax.mail.Service.connect(Service.java:118)
    Line 203: 09.04.2014 13:30:21  STDERR:     at javax.mail.Transport.send0(Transport.java:188)
    Line 204: 09.04.2014 13:30:21  STDERR:     at javax.mail.Transport.send(Transport.java:118)
    Line 205: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.sendMessage(Email.java:397)
    Line 205: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.sendMessage(Email.java:397)
    Line 205: 09.04.2014 13:30:21  STDERR:     at com.sygate.scm.util.mail.Email.sendMessage(Email.java:397)
    Line 216: 09.04.2014 13:30:21  STDERR:     at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:231)
    Line 217: 09.04.2014 13:30:21  STDERR:     at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:189)
    Line 218: 09.04.2014 13:30:21  STDERR:     at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1359)

"could not connect to smtp host" but i can reacht the smtp host from that server on port 25 via telnet...

Brɨan's picture

Do you have all the fields filled in correctly? I've seen happen before with upgrades/migrations. All fields need to be filled in.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

BREL's picture

I found the solution.

the smtp connection from symantec was blocked by the SEP Client itself. I had to deactivate "Autoprotect for E-Mails" in the SEP client.

SOLUTION
Brɨan's picture

interesting...thnaks for letting the community know

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.