Video Screencast Help

SEPM not getting latest updates

Created: 26 Sep 2013 | 14 comments
kintachi's picture

Hi,

I installed SEP 12.1 RU3. The installation was successful and SEPM was running well. However, it cannot get latest virus definition update. I run the luall.exe but it fails, and got an error. See attached image. Thanks.

1.png

Operating Systems:

Comments 14 CommentsJump to latest comment

James007's picture

Symantec Endpoint Protection Manager (SEPM) fails to LiveUpdate from internal UNC paths

 

Article:TECH102257 | Created: 2007-01-30 | Updated: 2011-08-15 | Article URL http://www.symantec.com/docs/TECH102257

Check this thread

https://www-secure.symantec.com/connect/forums/live-update-error-lu1814-sepm-11x

pete_4u2002's picture

ceck these links

A LiveUpdate session run within the Symantec Endpoint Protection Manager fails with error LU1814
http://www.symantec.com/docs/TECH93558

LiveUpdate concludes with Error code LU1814 while trying to update Symantec Endpoint Protection Manager Replication partner
http://www.symantec.com/docs/TECH177465

Ambesh_444's picture

Hello,

Please check internet connectivity. I think there is problem with your internet connection.

http://www.symantec.com/docs/TECH93558

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

SebastianZ's picture

Are you updating from internet or LUA? Both way check if you can ping the update server first? This looks like the communication issue between LU and Liveupdate server. If the connections is working finr though maybe it is worth reinstalling the Liveupdate component on this SEPM - you can follow below steps for this:

 

1. Remove Live update from "Add/ Remove Programs"
2. Reboot the machine
3. In Windows Explorer, if they are present delete the following folders, without saving the existing content (respectively to the used version and OS):
- C:\ProgramData\Symantec\LiveUpdate
- C:\ProgramData\Application Data\Symantec\LiveUpdate
- C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate
- C:\Program Files (x86)\Symantec\LiveUpdate (64bit)
4. Install LU using lusetup.exe (execute with local admin rights - build in administrator, take into consideration the appropriate LU version for your SEP/SEPM)
5. Re-register LU component with SEP Client or SEPM
* [SEPM] -> in C:\Program Files\Symantec\Symantec Endpoint Protection Manager\bin:
- Type lucatalog -cleanup and press Enter.
- Type lucatalog -forcedupdate and press Enter (SEPM 12.1)
* [SEP Client] -> run repair on the SEP client from "Add/ Remove Programs"
6. In  C:\Program Files (x86)\Symantec\LiveUpdate start luall.exe (execute with local admin rights)
7. Let the Live update express session run till the end and check if any errors are occuring
8. [SEPM ONLY] If the session was successfull check the path: "C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\content" to see if there is any content downloaded under respective moniker folders

Mick2009's picture

Hi kintachi,

"Thumbs up" to the good advice, above.

Screenshots can be useful, but the full story is likely in log.liveupdate.  Examine the most recent entries in there, and perhaps post the most recent session to the forum?  

Many thanks in advance!

With thanks and best regards,

Mick

SameerU's picture

Hi

Reinstall the liveupdates and check

Regards

 

Beppe's picture

 I agree with Mick the log.liveupate will tell you/us much more.

Anyway, most of LU issues are caused by networking issues, check your proxy settings.

Regards,

Giuseppe

SameerU's picture

Hi

What is the database you are using ?

Regards

 

kintachi's picture

Hi All,

Done on the procedures provided by SebastianZ, still the same error. We are also done on reinstallation of LiveUpdate and repair of SEPM. We encountered same error as of this time. For log.liveupdate.log, please see attached. Thanks all.

AttachmentSize
Log.LiveUpdate.txt 1.69 MB
SMLatCST's picture

As Ambesh mentioned before, it does seem like an issue connecting to Symantec Liveupdate on the internet in general as per the below log entries:

9/24/2013, 6:03:47 GMT -> Progress Update: TRYING_HOST: HostName: "liveupdate.symantecliveupdate.com" URL: "http://liveupdate.symantecliveupdate.com" HostNumber: 0
9/24/2013, 6:03:47 GMT -> Progress Update: TRIFILE_DOWNLOAD_START: Number of TRI files: 0	Downloading LiveUpdate catalog file
9/24/2013, 6:03:47 GMT -> LiveUpdate will download the first Mini-TRI file, liveupdate_3.3.100.15_english_livetri.zip
9/24/2013, 6:03:47 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
9/24/2013, 6:03:47 GMT -> Progress Update: PRE_CONNECT: Proxy: "(not-available)" Agent: "Symantec LiveUpdate" AccessType: 0x0       
9/24/2013, 6:03:48 GMT -> Progress Update: CONNECTED: Proxy: "(not-available)" Agent: "Wr73y+csROTJxfcw3Tc+X1+0pbIPCtBUgAAAAA" AccessType: 0x0       
9/24/2013, 6:03:48 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantecliveupdate.com/liveupdate_3.3.100.15_english_livetri.zip", Estimated Size: 0, Destination Folder: "C:\ProgramData\Symantec\LiveUpdate\Downloads"
9/24/2013, 6:03:48 GMT -> Unable to find the property 'PREFERENCES\MAX_LIVETRI_SIZE' in settings file; using default: 1048576.
9/24/2013, 6:04:09 GMT -> CSendHTTPRequest::SendRequest - Timed out while communicating with server.
9/24/2013, 6:04:09 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantecliveupdate.com/liveupdate_3.3.100.15_english_livetri.zip", Full Download Path: "C:\ProgramData\Symantec\LiveUpdate\Downloads\liveupdate_3.3.100.15_english_livetri.zip" HR: 0x802A0045
9/24/2013, 6:04:09 GMT -> HR 0x802A0045 DECODE: E_UNABLE_TO_REACH_SERVER
9/24/2013, 6:04:09 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x802A0045, Num Successful: 0
9/24/2013, 6:04:10 GMT -> HR 0x802A0045 DECODE: E_UNABLE_TO_REACH_SERVER
9/24/2013, 6:04:10 GMT -> EVENT - SERVER SELECTION FAILED EVENT - LiveUpdate failed to connect to server liveupdate.symantecliveupdate.com at path  via a HTTP connection. The server connection attempt failed with a return code of 1814, LiveUpdate could not retrieve the catalog file of available Symantec product and component updates.

I think it's worth noting that while the proxy checks came back with a 0x0 result, the LU Client still appreared to be trying to connect to a proxy server as higlight in italics above.  If no proxy is in use, I'd actually expect that to say "null" (as mine does).

Do you use a proxy?  What is configured in the LU proxy settings for the SEPM and do these differ from those in the LU settings in the Control Panel?

 

AjinBabu's picture

Hi,

Is any proxy is using to connect to internet?

Regards

Ajin

kintachi's picture

Hi,

We haven't use any proxy. Thanks.

pete_4u2002's picture

looks like it's timeout the issue

9/24/2013, 6:04:09 GMT -> CSendHTTPRequest::SendRequest - Timed out while communicating with server.
 

can you follow these steps and verify if it helps

1. As per OS, browse to

Windows 2003: Default location is C:\Documents and Settings\All Users\Application Data\Symantec\Liveupdate
Windows 2008: Default location is C:\Programdata\Symantec\Liveupdate.

2. Open Settings.Liveupdate, find

PREFERENCES\INTERNET_CONNECT_TIMEOUT=45
PREFERENCES\INTERNET_READ_DATA_TIMEOUT=45

Change the default setting of 45 to a larger number, for example 300.

3. Save Settings.Liveupdate.

4. Run LiveUpdate to verify success.

 

kintachi's picture

Hi Pete,

I will update you for the result. Thanks.