Video Screencast Help

SEPM v 12.1 RU1 LiveUpdate return error code = 4 in Live Updating ?

Created: 20 Aug 2012 | 17 comments

Hi people,

What should I do to fix this Live Update error return Code = 4 issue ?

my internal SEPM server is fine using the same Proxy account to download the update from the internet however, my DMZ SEPM returning an error in retrieving the update from the Internal SEPM server ?

Comments 17 CommentsJump to latest comment

pete_4u2002's picture

"Error: LiveUpdate encountered one or more errors. Return code = 4" in LiveUpdate status in Symantec Endpoint Protection Manager

http://www.symantec.com/business/support/index?page=content&id=TECH103112

Mithun Sanghavi's picture

Hello,

LiveUpdate encountered one or more errors Return code = 4 is a Generic Error.

Could you please upload the log.liveupdate?

That would help us understand the root cause of the issue.

Again, are you using any proxy?

Did you try disabling the Windows Firewall on the machine and checked ?

Also, When uninstalling and reinstalling LiveUpdate, are you using the correct client for SEP 12.1?  

http://www.symantec.com/business/support/index?page=content&id=TECH171060

Make sure you are using Liveupdate version 3.3.1.23- nothing earlier!

Windows LiveUpdate Client for Use with Symantec Endpoint Protection Manager 12.1
Article: TECH181305   |  Created: 2012-02-13   |  Updated: 2012-03-21   | 
Article URL http://www.symantec.com/docs/TECH181305

Also, check the Proxy settings in SEPM 12.1 if they are correct?

How to Update the Proxy settings in the Symantec Endpoint Protection Manager (SEPM) 12.1

https://www-secure.symantec.com/connect/articles/how-configure-proxy-settings-symantec-endpoint-protection-manager-sepm-121

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Dushan Gomez's picture

ok, I have checked that Live update from the Internal SEPM went successfully, but not in the DMZ SEPM

<Drive>:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Log.LiveUpdate

the error log shows that It cannot open  http://SEPMInternal-VM:7070/clu-prod/ URL ?

does that means if I want to retrieve the SEPM update from another SEPM server between sites internally, I will have to install Internal LUA server running at on that port ?

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

Mithun Sanghavi's picture

Hello,

Which version of LUA are you running?

Check this Article:

Updating downloads in an internal LiveUpdate Administrator 2.x Server using the downloads from an external LiveUpdate Server

http://www.symantec.com/docs/TECH106254

Check these Threads:

https://www-secure.symantec.com/connect/forums/lua-stopped-working-after-service-restart

https://www-secure.symantec.com/connect/forums/liveupdate-issue-dmz

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Dushan Gomez's picture

Thanks for the reply people,

So does this means that I will need to install the LUA v 2.3.1 in order for my DMZ SEPM to get the update regularly ?

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

Mithun Sanghavi's picture

Hello,

As you suggested , "The error log shows that It cannot open  http://SEPMInternal-VM:7070/clu-prod/ URL" which pertains to LUA distribution center.

LUA 2.3.1 is the latest version of LUA and is always recommended.

Check these Threads:

https://www-secure.symantec.com/connect/forums/lua-stopped-working-after-service-restart

https://www-secure.symantec.com/connect/forums/liveupdate-issue-dmz

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

pete_4u2002's picture

welll the SEPM should be able to browse this URL

http://SEPMInternal-VM:7070/clu-prod/

then it should have definition list available, if available then download.

Yes 2.3.1 is the latest version, it is strongly recommended to use this version. However if you are still unable to access this URL even after upgrade you will still have this issue.

Dushan Gomez's picture

Pete,

I have run netstat -ano on the SEPMInternal-VM and could not find anything listening on port 7070, but on 8014 and 8443 there are some.

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

Mithun Sanghavi's picture

Hello,

Do you have a LUA installed?

Could you please upload the log.liveupdate?

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Dushan Gomez's picture

Hm.. I'm afraid no, because it was suggested that I shouldn't install it on my Internal SEPM.

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

Mithun Sanghavi's picture

Hello,

Well, since LUA is not installed, we may have to check the Log.liveupdate as there may be something else which may be causing the error to occur.

Secondly, since it's a DMZ, check these Articles:

Best Practices: Configuring a Symantec Endpoint Protection environment in a DMZ

http://www.symantec.com/docs/TECH178325

How to update content on a Symantec Endpoint Protection Manager that doesn't have Internet access

http://www.symantec.com/docs/TECH104893

Updating downloads in an internal LiveUpdate Administrator 2.x Server using the downloads from an external LiveUpdate Server

http://www.symantec.com/docs/TECH106254

How to distribute definition content from a LiveUpdate Administrator 2.x (LUA 2.x) server to an isolated network.

http://www.symantec.com/docs/HOWTO44060

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

pete_4u2002's picture

that shows the connection, since nothing shows up on 7070, check the firewall is blocking. as asked is Internal LUA installed?

pete_4u2002's picture

if LUA is not installed, then you should change the LU policy accordingly.

Dushan Gomez's picture

Pete,

Where to set the Policy so that my DMZ SEPM can get the update from Internal SEPM server ?

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

Mithun Sanghavi's picture

Hello,

Check this Thread: https://www-secure.symantec.com/connect/forums/sepm-dmz-0

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

pete_4u2002's picture

SEPM can get the updates either from LUA or Symantec Liveupdate.

Else you need to manually update using jdb file.