Video Screencast Help

Server access not allowed error -46

Created: 21 Apr 2013 • Updated: 23 Apr 2013 | 5 comments
This issue has been solved. See solution.

bash-4.1# bptestbpcd -client HKGRAPNANPSF39
<16>bptestbpcd main: Function ConnectToBPCD(HKGRAPNANPSF39) failed: 46
server not allowed access

Operating Systems:

Comments 5 CommentsJump to latest comment

Marianne's picture

Have you ensured forward and reverse lookup between server and client? (Using DNS or hosts file)
Client needs to resolve the IP address in server's connection request to a hostname. Then it compares the resolved name with SERVER entries (bp.conf in Unix/Linux , registry in Windows).
Resolved name must match Server name exactly. (E.g. Master != master != master.fqdn).

Please create bpcd log folder on client under netbackup/logs, do bptestbpcd again, then post client's bpcd log here.
Also tell us which OS on server and client.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Hannible's picture

Hello,

the Media Server entry was missing in the Config file

and Netbackup client Services was stoped

updated the same..

and it worked..

thanks.

 

SOLUTION
SYMAJ's picture

Had exactly this issue today, and as per Marianne above it was down to resolution.

I ran the bpclntcmd -hn with success from both Media -> client and Client -> Media, bt the bpclntcmd -ip failed both ways.  I therefore suspected a DNS resolution issue, and the 'quick' way out with no access to the DNS server was to add a host file entry at both ends (I then ran a bpclntcmd -clear_host_cache to be sure and clear out any lingering resolution items) and this sorted the the issue.

Hope this helps.

AJ

Dyneshia's picture

also confirm firewalls are off or exceptions for ports have been made ( 13782 , 13724 etc )

Perwara's picture

If it is a Windows client, you might want to tweak:

HKLM > SOFTWARE > VERITAS > NETBACKUP > CURRENT VERSION > CONFIG

Here you would find a key called "Server" just double click and add the hostname of your master server.