Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Server could not install altiris agent when reboot to the pxe created by the ASDK 7.5

Created: 12 Sep 2012 • Updated: 18 Dec 2012 | 1 comment
This issue has been solved. See solution.

Hi all:

   I've installed the altiris deployment solution 7.5 and ASDK 7.5.

   First, I create a linux pxe image  from the Symantec Management Platform which we can call it PXE_A, and let my client server boot to this pxe image. The server can install the altiris server successfully!

   Then, I use the asdk function  to create a linux pxe image which we can call it PXE_B. It successfully too.

   But, after my cilent server boot to PXE_B, an error about altiris agent occurred as followed:

  

   So, I try to compare the rc.agent in PXE_A to the one in PXE_B, and found that the content of these two files are different completely!

the content of rc.agent in PXE_A is as followed:

    But the content of rc.agent in PXE_B is as belowed:

The code I used is worked in alritis 7.1 and ASDK 7.1.  Is there any different between this thwo version of ASDK.

After compare the ASDK 7.1 file to ASK 7.5 help file, I can not find different about the rc.agent. Is anyone know the mechanism in altiris about the generation of  the rc.agent. Thanks very much!

Comments 1 CommentJump to latest comment

Vaibhav Raut's picture

The below error is not DS 7.5 PXE image. It is DS 6.9 PXE image since it is showing “adlagent” and “EXPRESS” in the logs.

Cause of this error may be you are booting the client in wrong PXE image or PXE image that you created using ASDK is already present with same name and type DS6.9 pxe.

SOLUTION