Video Screencast Help

Server does not have recent updates ....

Created: 26 Jan 2013 • Updated: 06 Feb 2013 | 9 comments

I´ve got one Backup Server (2012) to backup for about 5 Servers and 8 Clients.

Rolled out the Agents every time after applying Hotfixes, ...

My server always sends me an alert at 22:00: Liveupdate Information - The Agent for Windows on at least on server does not have the most recent updates ...

Why can´t they just add a list of servers where I can find out, which server is affected?

Any other location where I can find out which system is making troubles?

I tried to find out which system is making troubles but although I added all systems in the installation-list for the windows agent

BExec just says everything is fine. Only my Microsoft TMG can´t be queried for remote installation but Backup is running fine.

I installed the Agent there manually and it is the newest version.

Question: what does BExec check to say that there is a problem?

 

Comments 9 CommentsJump to latest comment

DaveyMG's picture

Echoing the previous comment, it seems silly that the update alert tells you that one or more servers are out of date but then leaves you to work out which server(s) it's talking about.

Surely adding the name of the server(s) to the alert wouldn't be too hard?

Sym-cr@zy's picture

Hi STRGER,

Regarding the server name being added to the alert, I appreciate the idea of DaveyMG. However, currently to find out which server is not updated with the recent updates, please check the list of servers added under the Backup and Restore tab. Notice the icons or logo shown with all the servers (e.g. if it's a Win physical server- it will have a Windows logo, if it's a virtual machine- it will have a Windows logo in blue color), and the server which does not have the recent updates will show with a symbol of a globe with an arrow (Please refer the attached screenshot)

 

Update.jpg
          Appreciate every help you get, to help yourself better
                                  & 
      Please mark 'SOLUTION' for the post which resolved your issue.
DaveyMG's picture

Apologies!  You're quite right and if I hover the mouse over the icon it tells me there is an upgrade available.

STRGER's picture

Sorry, but I checked out my servers (and workstations). All Icons have the correct logo shown.

But still the message that there´s an agent out of date ...

Any ideas?

Sym-cr@zy's picture

Hi STRGER,

Sorry for a delayed reply. Please check the below option under Global Settings.

Application Menu-> Configuration and Settings-> Backup Exec Settings-> Live Update

Make sure the below option is not selected:

"Send an Alert when updates are available, do not download or install updates"

Instead select: "Download and install all updates automatically"

Refer the attached screenshot.

Also, just to let you know currently BE2012 program should have all these updates installed:

Service Pack 1

Hotfix 189571

Hotfix 180964

Hotfix 194470

Hotfix 199866

Hotfix 200433

Check for these updates on your media server. Application Menu-> Installation and Licensing-> Installed Updates.

Liveupdate.JPG
          Appreciate every help you get, to help yourself better
                                  & 
      Please mark 'SOLUTION' for the post which resolved your issue.
STRGER's picture

Thanks for your answer!

Allright - no alerts/messages today.

Changed the setting yesterday, besides that all updates are shown (like in your list).

Is this only a workaround (to kill the message) or did BExec now "really" update the missing clients?

What, if I change back to the old setting? Any logs (where) to find out if updates are done, everything is ok?

Sym-cr@zy's picture

Hi STRGER,

Glad to know that, the alerts aren't popping up anymore.

Is this only a workaround (to kill the message) or did BExec now "really" update the missing clients?

It's not a workaround but an option. However, the alert which you were receiving was not for the agents not updated but for the media server itself. Updates to the agents should be pushed.

Two methods to push updates:

1. Choose either one or more servers at a time in Backup and Restore tab  and click "Update" button at the top, also

 2. You can select the servers you want to update right click and update them (if the update option is grayed out means the server is already up-to-date).

Option in BE2012 (not available in 2010):

Install updates options

http://www.symantec.com/docs/HOWTO74339

What, if I change back to the old setting?

My suggestion would be to stay with the option "Download and install all updates automatically". When using other option sometimes, if we fail to address the alert and miss to install some important/critical hotfix or service pack, we can put our BE in trouble and so our servers.

Any logs (where) to find out if updates are done, everything is ok?

App Menu-> Configuration and settings-> Audit logs.

Choose "Select category to view" as "Install". (It will show you if the media server downloaded and installed the updates successfully)

Hope I was able to address all your concerns smiley

 

          Appreciate every help you get, to help yourself better
                                  & 
      Please mark 'SOLUTION' for the post which resolved your issue.
STRGER's picture

Thanks so far.

Seems to work.

There was no entry in the audit-log for install.

So I´m still confused, why Bexec insisted that there´s an update missing...

 

Linas's picture

I too keep getting message “The Agent for Windows on at least one server does not have the most recent updates. To install the most recent updates, on the Backup and Restore tab, right-click the remote computer that is out of date, and then select Update.

I followed all the fixes

All icons look updated

All versions the same

Ran LiveUpdate no new updates?

Have been getting this message for months only noticed now when clearing logs

Should I update all clients?

I don’t want to if I have to reboot any of the servers?