Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

server name not found in netbackup configuration

Created: 22 Feb 2013 • Updated: 25 Feb 2013 | 6 comments
kp-'s picture
This issue has been solved. See solution.

Fresh install of Netbackup 7.5 on a physical server. Windows 2008 R2 Standard SP1. Media and master is on the same machine. 

When I open admin console (not java) I click on Storage-->Storage Units. I get the following error: "Server name not found in the Netbackup configuration"

What did I do, or not do to cause this? I'm following Chapter 10. Configuring disk storage in the admin guide for basic storage and it says I need to create a storage unit. I have an 8TB Raid5 array on the local disk for my backups of VM's. First NBU setup, so please be gentle.

Thanks for your help!

Operating Systems:

Comments 6 CommentsJump to latest comment

Marianne's picture

2 possible issues (that I can think of):

  1. W2008 and UAC
    I have seen all sorts of weird and wonderful errors on W2008 with UAC enabled. Some actions in NBU will work fine and others will error out.
    Either disable UAC or else remember to always open NBU GUI with right-click, Run as Administrator. Same applies to opening cmd for command-line actions.
  2. Hostname resolution
    Was NBU installed with shortname or FQDN?
    Everything in NBU revolves around hostnames plus NBU is case sensitive:
    MASTER != master != master.fqdn

If you feel that none of the above is the case, please provide screenshots of your STU creation steps and also output of this command (in <install-path>\veritas\netbackup\bin\admincmd):
nbemmcmd -listhosts -verbose

 (remember to open cmd with Run as Administrator)

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

kp-'s picture

Hi Marianne van den Ber,

I forgot to mention I disabled UAC during the install as I seen that reccomondation elsewhere. UAC is also disabled until I can figure this out. Firewall is also disabled if that matters. (internal network so not worried)

I also did run the install as admin. I also opened the console as an admin, Unfortually I'm seeing the same error.

I did install NBU with the FQHN.. The first install was the shortname, so I reinstalled, rebooted and installed with the FQHN.

Not sure what your asking for in regards to the STU creation steps... Would be happy to provide this info. Here is the results from the command. I did remove out the domain for privacy reason otherwise output as is.

 

c:\Program Files\Veritas\NetBackup\bin\admincmd>nbemmcmd -listhosts -verbose
NBEMMCMD, Version: 7.5
The following hosts were found:
wenetbackup.domain.com
        MachineName = "wenetbackup.domain.com"
        FQName = "wenetbackup.domain.com"
        MachineDescription = ""
        MachineNbuType = server (6)
wenetbackup.domain.com
        ClusterName = ""
        MachineName = "wenetbackup.domain.com"
        FQName = "wenetbackup.domain.com"
        GlobalDriveSeed = "VEND:#.:PROD:#.:IDX"
        LocalDriveSeed = ""
        MachineDescription = ""
        MachineFlags = 0x16
        MachineNbuType = master (3)
        MachineState = active for disk jobs (12)
        NetBackupVersion = 7.5.0.0 (750000)
        OperatingSystem = windows (11)
        ScanAbility = 5
sysvcenter.domain.com
        MachineName = "sysvcenter.domain.com"
        FQName = "sysvcenter.domain.com"
        MachineDescription = ""
        MachineNbuType = virtual_machine (10)
Command completed successfully.

Thanks for the help!

RamNagalla's picture

are you using DNS or etc/hosts for the master server.

how your DNS or /etc/hosts entries looks like?

kp-'s picture

Nagalla,

Master server is also media server...

IP to FQHN in hosts file...

Thanks!

Marianne's picture

Some more command output please (in C:\Program Files\Veritas\NetBackup\bin\):
bpclntcmd -self

bpclntcmd -hn wenetbackup.domain.com

bpclntcmd -ip <master>

Is master server name showing up correctly in top left corner of the GUI?

Where does sysvcenter.domain.com fit in the picture?

PS: Please patch NBU to 7.5.0.4 or 7.5.0.5 ASAP (too many bugs in unpatched version. 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
kp-'s picture

Marianne van den Berg,

I was not sure what version I had, so your comment about not having the latest 7.5.0.4 or 7.5.0.5 was concerning... So I patched the system to 7.5.0.5. 

 

Is master server name showing up correctly in top left corner of the GUI? No, it says localhost.

So I went File-->Change Server. Put in the FQHN of my master server i.e wenetbackup.domain.com. The master server shows he FQHN instead of localhost now..... and I can now create a storage unit. 

Thanks all for the help!