Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Service Desk/Workflow 7.5 Screen Capture errors out if "Allow Remote Connections" is disabled.

Created: 23 Jan 2013 • Updated: 26 Aug 2013 | 5 comments
QuietLeni's picture

Dear All,

If your organisation uses the Screen Capture Utility, then the Utility will error out (saying that the remote computer actively refused the connection) in ServiceDesk 7.5 if you do not set the "Allow Remote Connections" in the Server Extensions Configuration.

Symantec advise that this setting should only be switched on if you are updating the Workflows and using the Workflow Designer, but if you do, then the Screen Capture Utility also stops working.

Hope that this helps someone else (and you vote it up if it did)!

Kindest regards,

QuietLeni

Comments 5 CommentsJump to latest comment

reecardo's picture

Is this erroring out when you do a certain piece of functionality, like Send to Process Manager?

I just tried opening it up and saving a screenshot and it appears to be working. I'm doing this in Workflow, however... not ServiceDesk.

QuietLeni's picture

Yes, it was at "Send to Process Manager"! Did I not specify that; d'oh!?!?

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

gBBB's picture

QuietLeni,

This was a good callout, as I'm sure other customers will be affected. There is a workaround to allow you to use the 'Upload to ProcessManager' functionality from the screen capture utility without having to enable the Allow Remote Connections option:

1. Edit the SD.IncidentManagementSimple.EndUserRequest project in Workflow Designer

2. Edit the 'Create SShot URL' component in the Model: Primary

3. Change the existing URL:

sshot://[[ProjectProperties].ServerIPAddress]?mx=lme://[[ProjectProperties].ServerIPAddress]/remote.snapshotqueue&mid=[SnapShotID]

To this new URL:

sshot://[[ProjectProperties].ServerIPAddress]?mx=lme://127.0.0.1/remote.snapshotqueue&mid=[SnapShotID]

4. Save and publish the project

 

This should resolve the issue by using a internal localhost call during the screenshot post on the ServiceDesk server, instead of using the published server address.

QuietLeni's picture

gBBB,

Hmm. I think that this should be a fix to the product. The product should be able to work properly, out-of-the-box and not require this change, with good security implemented.

What do you think?

Kindest regards,

QuietLeni

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

gBBB's picture

I neglected to note this in my original response, but I did record this as a ticket in our internal system (as we do with many of the issues raised in this forum). Look for it to be fixed in a future release. 

Thanks for the feedback.yes