Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Service group unable to failover after shutting down active with VCS 5.1 on windows server 2008 R2

Created: 18 Aug 2010 • Updated: 22 Sep 2010 | 7 comments
Chandrakant Bagde's picture
This issue has been solved. See solution.

Hi ,

Please provide solution on after shutting down active node resources are not failover on the passive node, it showing active node as faulted and passive node remains in offline mode.

I am performing this on windows 2008 R2 with VCS 5.1 SP1. I have tried increasing  VCS_GAB_TIMEOUT, however it didn't help to resolve the issue.

Comments 7 CommentsJump to latest comment

ocgomo's picture

       Espero me puedan ayudar, desde que instale la nueva versión del SMSMSE, no está funcionando al 100%, agrego una dirección a la lista de remitentes bloqueados, pero el correo entra de igual forma. Además en la versión anterior tenía la posibilidad de salvar  los correos filtrados en una carpeta en el servidor, para luego revisarlos, esto me permitía monitorear si las reglas estaban cumpliendo su objetivo, pero en esta versión solo me permite eliminar los correos filtrados, o enviarlos a cuarentena, pero se complica porque, además de notificar al usuario cada vez que coloca un mensaje en cuarentena, no me deja ver el cuerpo del mensaje, dificultando la tarea de liberar el correo.

        En cuanto a las reglas, estas son las acciones que me permite, en la versión anterior (La cual nos funcionaba al 100%) me permitía salvar el ítem en una carpeta del Servidor, para luego revisar y reenviar al usuario los positivos, pero en esta versión:
·         Borrar-> No me permite analizar los falsos/positivos
·         Remplazar el cuerpo del mensaje-> Me deja pasar los falsos, y me borrar la info en los positivos.
·         Cuarentena -> Notifica a los usuarios de N mensajes, todos los que ponga en cuarentena
·         Agregar un tag al subject-> igual que la anterior
·         “Log only”-> No genera valor alguno.
 Esta imagen muestra las opciones de que el usuario dispone.. sin embargo

Marianne's picture

Please go to Mail Security for Exchange/Domino Forum and Start a new discussion.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Gaurav Sangamnerkar's picture

Hi Chandrakant,

Can you confirm following:

-- AutoFailover setting for service group is set to 1   ?
-- Systemlist for service group contains both the nodes in it ?

Failover doesn't happens at all OR you see some errors while failover ?

Gaurav

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

Chandrakant Bagde's picture

Hi Gaurav

We have configured  failover policy as priority that is by default, and cluster failover policy as manual that is also deafault.

We have also added both the nodes which are part of cluster within autostart list.

We will able to switch over manaually, even after when we disable one NIC, resources are able to failover properly. However when we shut down active node then it remains in autodisable and resources are not failover to other node.

Marianne's picture

Have a look at this TechNote http://seer.entsupport.symantec.com/docs/348233.htm:

ShutdownTimeout comes into effect only after HAD has been killed while GAB_ISOLATE_TIME comes into effect after the port 'h' is closed but before the node goes down. VCS can clear the autodisable flag itself, but the machine must be able to unload GAB within 120 seconds of VCS had engine hanging or dying, which means the machine must go down.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Gaurav Sangamnerkar's picture

Hi Chandrakant,

Also can u confirm about AutoFailover value for group ? it should be 1  .. for e.g

ClusterService   AutoFailOver          global          1

ClusterService   ClusterFailOverPolicy global          Manual

ClusterService   FailOverPolicy        global          Priority

Can u paste, hagrp -display  for the group in concern ?

Also paste the group defination from main.cf ...

Also the probability of what Marianne said above is high, can u confirm that as well ?

Gaurav

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

Chandrakant Bagde's picture

Hi Gaurav,

Issue got resolved after increaing ShutdownTimeout  value by using  # hasys -modify sysname ShutdownTimeout <New time>.

We were performing this installation within Vmware guest machine, and we notice it was taking long time to shut down. By default the ShutdownTime value is 120 sec. and we increase the same by 400 sec and found the issue got resolved.

Thanks to you and Marianne's support to isolate this issue.

SOLUTION