Video Screencast Help

ServiceDesk Workflow Installation getting failed

Created: 06 Feb 2013 • Updated: 11 Feb 2013 | 5 comments
Mahendra Patel's picture
This issue has been solved. See solution.

Hi, 

I am trying to install servicedesk 7.5 but while installing the servicedesk server I am getting error in the part where workflow is installed. the error is something related to Sql server. I tried to search but couldnot find any solution.

I am a noob in database stuff, All the log files are attached with this post.

I followed the implementation guide till now and all the test for database connection as well as SMP connection were successful.

Please help me out

Thanks

Comments 5 CommentsJump to latest comment

Mahendra Patel's picture

anyone?

 

I think the problem lies in these errors

 

 

Load up parameters file: C:\Users\servicedesk\AppData\Local\Temp\__Symantec_Workflow_Setup\input.xml
Getting current database version..
Error getting current database version: Cannot open database "ProcessManager" requested by the login. The login failed.
Login failed for user 'TTBS\servicedesk'.
.
.
.
.

 

Error running installer in silent mode:
System.Exception: 'System Check' page is not valid:
The SQL Server Edition could not be detected
   at Symantec.Workflow.Installer.Program.RunSilentInstall()
 
 
 
 
What could be the proble as I have created a separate domain user and added that user to sql server logins and given sysadmin permissions. I am also using the same account to install servicedesk.
Mahendra Patel's picture

Ok, I have tried like all the combinations of useraccounts to install this but I am getting the same error as mentioned on the previous post.

 

Can someone tell me what should I do on Sql server to make this installation successful?

 

Thanks

TGiles's picture

Per the error it appears to be failing due to the SQL version being detected is not supported.

Run the following query to see what version information SQL is returning to the installer

SELECT SERVERPROPERTY('productversion'), SERVERPROPERTY('productlevel'), SERVERPROPERTY('edition')

reecardo's picture

There was a recent bug around this: 2964349 Cannot find SQL Version info.

Our installer was basically unable to detect the one-off "Data Center" edition of SQL Server. This was fixed in Workflow 7.5... however, I don't see it appearing in the 7.5 Workflow branch that ships with ServiceDesk.

If you have the option to NOT use the Data Center edition of SQL Server, and have another edition available, this would get around the error. Otherwise, we'd have to update the installer.

SOLUTION
CNWilliams's picture

Symantec ServiceDesk 7.5 Release Notes

http://www.symantec.com/docs/DOC5720

ServiceDesk 7.5 Known Issues:

Issue Description Article link
You cannot use SQL 2008 R2 Datacenter edition to build your SQL Server.

If you attempt to install ServiceDesk 7.5 to SQL Server 2008 R2 Datacenter edition, the prerequisite check fails and you cannot continue.

Workaround:

Do not use SQL 2008 R2 Datacenter edition to build your SQL Server.

SQL 2008 R2 Datacenter is currently not supported.

 

 

Kindest Regards,

CNWilliams

 

 

CNWilliams