Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SET UP NETBACKUP 6.5 SAN CLIENT

Created: 06 May 2010 • Updated: 08 Nov 2010 | 3 comments

I am trying to configure netbackup to backup through SAN. The initial step of setting up the target mode for the port to be used by clients has failed. Note that I have one netbackup server and is also the media server. It has two fc ports. Now when trying to start the process of setting the target mode for the second hba, the FT server config is unable to succeed. The OS is Solaris 10. I already run nbftconfig using procedure from documetation from Veritas. Please assist.

/usr/openv/netbackup/bin/admincmd/nbftconfig -ls
No FT servers found

/usr/openv/netbackup/bin/admincmd/nbhba -l
Unable to communicate with HBA ports.
Please ensure that this system is set up correctly with nbftsrv_config.
(Must not be set up as FT Server.)
Error #11: system call failed

Comments 3 CommentsJump to latest comment

Andy Welburn's picture

FT Driver - Error #11: system call failed

Details:


ISSUE: When trying to configure FT driver on Solaris 10 you get
Error #11: System Call Failed
 
TROUBLESHOOTING STEPS:
When trying to configure HBA, an error occurs.
# ./nbhba -l
Unable to communicate with HBA ports.
Ensure that the system is set up correctly with nbftsrv_config.
(Must not be set up as FT Server.)
Error #11: system call failed

SOLUTION:

Remove NetBackup FT drivers, reinstall Solaris 10 Fiber Channel patches 125184-08 and 125166-12 then reinstall the NetBackup FT drivers

powplug's picture

When I try to apply the advised patches 125184-08 and 125166-12, the system reports " All packages from patch 125184-08 are patched by higher revision patches" . This happens for both patches. See Below. Note I patched the system with an EIS DVD from Sun before installing veritas netbackup.

# showrev -p |grep 142084
Patch: 142084-02 Obsoletes: 125166-13, 125392-02, 139606-02 Requires: 119130-33
Incompatibles:  Packages: SUNWqlc, SUNWqlcu
# showrev -p |grep 125184
Patch: 141874-04 Obsoletes: 120182-06, 120346-09, 125184-11, 125390-02, 128146-0
3, 128148-01, 139604-06 Requires: 119130-33 Incompatibles:  Packages: SUNWcfcl,
SUNWcfclr, SUNWfctl, SUNWfchba, SUNWfcip, SUNWfcmdb, SUNWfcp, SUNWfcsm
Patch: 141874-06 Obsoletes: 120182-06, 120346-09, 125184-11, 125390-02, 128146-0
3, 128148-01, 139604-06 Requires: 119130-33 Incompatibles:  Packages: SUNWcfcl,
SUNWcfclr, SUNWfctl, SUNWfchba, SUNWfcip, SUNWfcmdb, SUNWfcp, SUNWfcsm
# showrev -p |grep 141874
Patch: 141874-04 Obsoletes: 120182-06, 120346-09, 125184-11, 125390-02, 128146-0
3, 128148-01, 139604-06 Requires: 119130-33 Incompatibles:  Packages: SUNWcfcl,
SUNWcfclr, SUNWfctl, SUNWfchba, SUNWfcip, SUNWfcmdb, SUNWfcp, SUNWfcsm
Patch: 141874-06 Obsoletes: 120182-06, 120346-09, 125184-11, 125390-02, 128146-0
3, 128148-01, 139604-06 Requires: 119130-33 Incompatibles:  Packages: SUNWcfcl,
SUNWcfclr, SUNWfctl, SUNWfchba, SUNWfcip, SUNWfcmdb, SUNWfcp, SUNWfcsm
## showrev -p |grep 125166
Patch: 142084-02 Obsoletes: 125166-13, 125392-02, 139606-02 Requires: 119130-33
Incompatibles:  Packages: SUNWqlc, SUNWqlcu
Andy Welburn's picture

I cannot find anything else specific so maybe it would be worth calling Tech Support?

There are a few other links that I have found which may be of assistance:

In the Ideas section https://www-secure.symantec.com/connect/idea/bette...

And also a T/N that recommends users of SAN client upgrade to 6.5.6 (or 6.5.5 and apply an EEB from Symantec) which resolves multiple issues: http://seer.entsupport.symantec.com/docs/338256.htm