Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SFM 2.1 - Error in creating a self signed SSL Certificate

Created: 19 Apr 2010 • Updated: 27 May 2010 | 1 comment
This issue has been solved. See solution.

I have been trying to creat a self signed SSL Certificate on SFM 2.1.
I have been using this http://seer.entsupport.symantec.com/docs/332313.htm as a reference when doing this.

When I did run the command "webgui cert create" the first time, I could se that the default certificate that was in place after the installation of SFM, was deleted.
The next step, creating a certificate failed.

When I tried "webgui cert create" again", it still failed.
The output is:
"keytool error: java.lang.Exception: Alias <tomcat> does not exist
keytool error: java.io.IOException: Incorrect AVA format
Error creating SSL certificate"

I can not access the SFM website anymore, and need som hints om how to fix this.

Comments 1 CommentJump to latest comment

srikanthkapila's picture

HI jseleniu,

This is Srikanth Kapila, an engineer with Symantec Corporation.  Can you please try out the following steps and let me know if that works out for you.

1.  Navigate to VRTSsfmcs/esmweb/webgui/cert directory under the install location. Check if the files .keystore and .keystore.prev exists. These files are hidden so you might have to use ls -a to see them on linux and solaris.
2. If yes, then perform the following.
export ESMWEB_INSTALL_DIR=/opt/VRTSsfmcs/esmweb on linux and solaris or set ESMWEB_INSTALL_DIR="<<install dir of esmweb>> ".
Then run the above command, it should work
3. If above cert directory doesnt exists or .keystore files are not present, create the directory and touch the .keystore file.

Do let me know if this solve the problem or if you need more information

Regards,
Srikanth

SOLUTION