Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

sg.build in AIX

Created: 27 Dec 2012 • Updated: 10 Jan 2013 | 3 comments
This issue has been solved. See solution.

Hi

Master server - solaris

Media server - AIX 

 

To fix  Missing drive path on Master server

I run

 

bp.kill_all--shutdown netbackup

 

1. Remove the drives from NBU config (tpconfig -delete -drive <drive index>

                                       (tpconfig -l   ---> for drive index)

2. Remove the /dev/rmt/ files 

                                        ($rm /dev/rmt/#cbn)

3. Run devfsadm -C -c tape

 

cd /usr/openv/volmgr/bin/driver
sg.build all -ml 9 (where 9 is the highest lun)
 
rm /kernel/drv/sg.conf 
/usr/openv/volmgr/bin/driver/sg.install
 
devfsadm -C -c tape
 
sgscan
 
bp.start_all
-------------------------------------------------------------------------------------------------------------------------
Drives shard with SSO
 
How can I do same in AIX to Fix Missing Drive path
 
https://www-secure.symantec.com/connect/forums/missing-drive-path-1#comment-8115561

Comments 3 CommentsJump to latest comment

Marianne's picture

Try this topic in AIX chapter of NBU Device Config Guide:

Configuring tape drive device files in AIX.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mph999's picture

There is no sg driver in aix.
You may need the ovpass driver but this is dependant on if you are not using ibm drives are at nbu 7.x

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Ah45's picture

 Aix media server

I have rebuild the devices with this procedure

tpconfig -delete

 rm /dev/rmt34.1

rmdev -dl rmt0

 lsdev -Cc tape

cfgmgr -v

 after these missing drive path got fixed...on AIX media server with SSO

SOLUTION