Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Shared Memory File Already Exists

Created: 04 Jun 2012 | 6 comments

I have recently started getting an error code 191 (Shared Memory File Already Exists).  These are the duplication jobs that are being written to tape. 

 
6/4/2012 3:34:48 AM - Info bptm(pid=6304) media id N00034 mounted on drive index 1, drivepath {4,0,0,0}, drivename IBM.ULTRIUM-TD3.001, copy 2
6/4/2012 3:34:48 AM - Info bptm(pid=6304) INF - Waiting for positioning of media id N00034 on server puck2 for writing.
6/4/2012 3:35:10 AM - Error bpdm(pid=5928) The "Global\NetBackup Media Manager SHM Info Path venus_1336266601_copy1_2" shared memory file already exists.
6/4/2012 3:36:05 AM - Error bpduplicate(pid=6464) host puck2 backup id venus_1336266601 read failed, file open failed (12). 
6/4/2012 3:36:05 AM - Error bpduplicate(pid=6464) host puck2 backupid venus_1336266601 write failed, termination requested by administrator (150). 
6/4/2012 3:36:05 AM - Error bpduplicate(pid=6464) Duplicate of backupid venus_1336266601 failed, termination requested by administrator (150).  
6/4/2012 3:36:05 AM - Error bpduplicate(pid=6464) Status = no images were successfully processed.     
6/4/2012 3:36:05 AM - end Duplicate; elapsed time: 00:02:01
no images were successfully processed(191)

Comments 6 CommentsJump to latest comment

Nicolai's picture

This bug was reported backup in Netbackup 6.5.4

BUG REPORT: NetBackup Storage Lifecycle Policy (SLP) duplications may fail with Status Code 50.

http://www.symantec.com/docs/TECH72227

The bug message is however diffrent - You have

The "Global\NetBackup Media Manager SHM Info Path venus_1336266601_copy1_2" shared memory file already exists

while the bug reported say:

6/29/2009 7:39:14 PM - Error bptm(pid=7016) Could not open file Global\NetBackup Media Manager SHM Info Path client_1246244490_copy1_3 to get shared memory information, The system cannot find the file specified.

Are you on 6.5.x ?

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

mph999's picture

Probably this one ...

 http://www.symantec.com/docs/TECH71352

 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
mph999's picture

OK, are there any hanging bptm processes 

Stop all jobs, kill any bptm processes, retry ...

 

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
RCBrown_DKH's picture

There are zero bptm processes at the moment.  I did just update the Admin Console to 7.1.0.3 to see if this clears up any issues.

mph999's picture

I can't find any examples of this in the DB - you might need to log a call.

 

First though, if you restart everything - Master + media) does it then work ?

M

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805