Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Sharepoint exclusions

Created: 30 Jan 2013 • Updated: 01 Feb 2013 | 6 comments
This issue has been solved. See solution.

I have lots of Sharepoint documentation and have reviewed it and searched the web but I have not learned what server the exclusions should be on.  I'm also unclear as to exactly what should be excluded.  I have made a guess that they are excluded in the Database Server.

Also we have some Content-DB x that are empty and causing errors in the details section in Activity Monitor.  The backup pauses when it comes to these DBs and sometimes times out.  We exclude the ldf and mdf because they are backed up with the MSSQL policy.    Please help.

See the attached screenshot.

Comments 6 CommentsJump to latest comment

Mark_Solutions's picture

This one is quite handy - does say set exclusions on all nodes:

http://www.symantec.com/docs/HOWTO73106

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

trs06's picture

Our farm servers are not clusters.  Thank you for sharing the article.  It describes a MS Database server cluster where there exists multiple nodes for high availability.  Putting the exclusions on each node is correct since any one node can be the active node in the cluster.  I don't read the article as meaning that the exclusions need be on all servers in the farm (our farm has two front end, two application and one DB server).  However, it does say put the excludes on the DB server as I have done and doesn't mention if it should go on any of the others.

That is what I have done and the exclusions for the indexdb* seem to work but not the ones I put in for the Content-DB x (in my case Content-DB 4).  I entered the exclusions via copy and paste and have looked them over carefully for any mistakes and found a missing ":" on one (fixed) -- still they don't work.  What am I doing wrong please.

Mark_Solutions's picture

The only difference i can see is that the ones that do not work do nat have a * on the end

The ones that work do - maybe worth a try

If you are worried they may be wrong just look on the client in its registry as they are stored under

HKLM\Software\Veritas\NetBackup\CurrentVersion\Config and it is the exclude registry key

I believe they should only go on the DB Server as you have them

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

trs06's picture

Thank You.  I thought of that to (*) so I tried adding it and it made no difference.  I'm wondering if it's a windows thing with directory trees with spaces.  The end of the exclude is Content-DB 4  with a space between DB and 4.  I was thinking next to try putting the whole thing in quotes like I would if I were going to run something command line in Windows.  I don't have access to the server so will have to get some help with that.

trs06's picture

Putting the string in double quotes didn't work either.  What I have learned though is that if you go to the Front End server, launch Netbackup Client, open the backup window, navigate the tree and find what you want to exclude in the right pane then right click on the item you will get a dropdown with a selection to exclude the object.  This does put the exclusion into the registry of the Front end server so if you want it in the database servers registry you can copy and paste it from the Front End to the DB server.  I have it in both - figured it wouldn't hurt anything to be in both.

BUT.  Now that I have done that I let the scheduled job run expecting wonderful results.  What I got was the job starting and 50 seconds later failing with 196 (bogus error message in this case).  This seems to be another Netbackup issue I have seen out on the web:  jobs would run manally but fail from the Netbackup scheduler.  I kicked off this same job manually just now and it's running well.  No changes, nothing touched or different execept one from scheduler and one manually.  I apologize for complaining in this forum but the Symantec/MS Netbackup integration for Sharepoint has been extremely irritating and unpleasant.  I am grateful for this forum and the people who support it.  You have been helpful, attentive and responsive with solid answers and solutions.

Mark_Solutions's picture

The guide does suggest opening the policy and browsing to the item you want to exclude, selecting it and then copying that path to the exclude list so i assume they appreciate it is not always easy to get it all right

I guess putting the exclusion everywhere doesn't hurt anyway - on the front end it sees it before doing the resolving but would still prefer it everywhere to be sure

Let us know how it all goes

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION