Video Screencast Help

Short file names are not created in wsi.

Created: 01 Feb 2013 | 6 comments

Hi,

when I run setup capture I don't get any short file names in the wsi.

Is there a setting somewhere where you can turn this on or off?

I need the short file names.

Thanks 

Comments 6 CommentsJump to latest comment

EdT's picture

What version of what Wise tool are you using?

Where are the shortfilenames missing?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

piyushnasa's picture

This will give you more insight and help.

http://msdn.microsoft.com/en-us/library/windows/desktop/aa371851(v=vs.85).aspx

Use this property in WSI.

Piyush Nasa Altiris Certified Professional (ACP)

http://msiworld.blogspot.com/

EdT's picture

Set it in the property table and make sure that the directory table has valid shortfilename entries as well as the longfilenames.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

KingVoodoo's picture

Thanks for all the replies.

We are using Wise Package Studio 7 sp3.

The problem is when I do a setup capture, I don't get any short file names anywhere in the wsi file.

E.g.  DatabaseFile.mdb will not have a short file name in the file table when i do a setup capture.

If I add the file manually I do get a short file name Databa~1.mdb|DatabaseFile.mdb in the file table.

What am I doing wrong sad

 

 

EdT's picture

There are no configuration settings to control this, that I am aware of.

What operating system are you capturing on?

Are you using local capture or web capture?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Jagadeish's picture

Make sure that the following registry key value is 0 in the packaging build

  1. Run Regedit
  2. Navigate to the key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
  3. This key should include a value NtfsDisable8dot3NameCreation
  4. Set the value to 0.
  5. To apply the change, restart the machine

http://technet.microsoft.com/en-us/library/cc959352.aspx