Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Silent Software Deployment Results in Error -2147213312

Created: 17 Jan 2013 • Updated: 18 Jan 2013 | 6 comments
This issue has been solved. See solution.

I am attempting to deploy JMP 10 via a managed software deployment policy. This software's installer is an Install Shield .exe file. I have followed the deployment guide provided by the software vendor to create a .iss file for a silent install:
http://www.jmp.com/administrator/pdf/jmp1002/jmp10_deployment_guide.pdf

If I run this silent installer manually it succeeds with no issue. If I run it in interactive mode via managed software deployment policy it succeeds with no issue. Every time I run it in silent mode via managed software deployment policy it fails with a return code -2147213312. I am not finding any solid documentation that defines this error code or what causes it. I have tried running my policy with both the Symantec Management Agent credential and providing a domain admin credential and get the same results in both scenarios.

Does anybody have any experience with this error code and how to correct it? Or does anybody have any other thoughts what about installing an Install Shield .exe passing a .iss answer file via managed deployment could be problematic?

Thank you.

Running Management Platform 7.1 SP2.

Comments 6 CommentsJump to latest comment

AngelD's picture

Enable logging; -f2C:\MyIS.log (no space between f2 and C:), and see what error installshield is giving you;

[ResponseResult]

ResultCode=-x

 

Also; please post the command your are using, usually you need the full path to the answerfile (.iss) and the -SMS switch.

 

sirNARVY's picture

Thank you for the reponse. The log file shows ResultCode=-3. I swear that when I looked at the log yesterday it showed ResultCode=0, but I hadn't ever provided a definite path to a log file, so the log file I was reviewing may have been from a different install attempt.

I'm new to dealing with ISS installers, but I found that this result code indicates information is missing from the .iss file I recorded. I've opened the .iss file, but since I don't have any experience with them, I'm not sure what I'm looking for.

This installer has four prerequisites including a version of Java Runtime Environment. I don't know if this is related or not, but it appears that every time I attempt the JMP install, successful or otherwise, an MsiInstaller error 1316 is written in the Application log that states "A network error occurred whole attempting to read from the file C:\windows\system32\config\systemprofile\AppData\LocalLow\Sun\Java\jre1.6.0_24_x64\jre11.6.0_24.msi. I find it odd and confusing that there would be a network error when attempting to communicate with a file on the local C drive, but again I don't know if these issues are related. Especially since this error seems to be posted even if the JRE is already installed, or installs successfully as part of the JMP install.

I notice when the install runs that I briefly get a popup that looks like an MSI installer extracting files. That dialog isn't on the screen long enough for me to confirm the files being extracted, but based on the MsiInstaller errors I'm getting on each execution that relate to the JRE, I suspect the dialog is from the JRE installer attempting to run. Might this suggest that the .iss file is failing because it has no information on how to respond to that MSI?

I have also opened a case with Symantec Support. They contacted me and told me the error code suggests a conflict with Symantec Endpoint Protection running on the target computer. Per their recommendation I disaled SEP on the target computer, but I continue to get the error.

The command I was using is:
"setup.exe" -s -f1ISS\x64.iss

My .iss file is in a subfolder of the uploaded package named ISS. Adding the -sms switch to the end of this command yields the same results.

 

Thanks.

AngelD's picture

Have you tried the below? Also try specify the full path to the ISS (ex. -f1"C:\my path\x86.iss")

"setup.exe" -s -f1.\ISS\x64.iss

 

SOLUTION
sirNARVY's picture

Thanks for those thoughts Angel. I tried using the .\ path, but still got the same error. Since I uploaded my .iss file into my software package, I wasn't sure how to properly reference the full file path. Instead, I copied the .iss file to a server share outside my library and referenced that path. Using that method I finally got the policy to succeed. I don't love the fact that I can't have the .iss file bundled with the deployment package, but at least it's successfully installing now.

Thanks again for your time and effort. Much appreciated.

AngelD's picture

In thouse cases I use a vbscript to "build" the command where I fetch the script path in combination with the file to make up the full path of the specific file(s) for a working command line.

Maybe something you can invoke in your case.

AngelD's picture

Note to me self: don't try to type too late at night wink