Video Screencast Help

SIM 7.1.55 - Installation CMS did not create Database

Created: 10 Mar 2011 | 9 comments
BeatIT's picture

Hi all,

i tried to install CMS 7.1 on a machine with remote SQL Server.

Management Server is 2008 R2 x64 meeting all requirements.

SQL Server is SQL 2008 R2

Appropriate rights (DB Creator) are given, the SQL Server is acessible.

I ran through the setup of SIM wich looked fine at first.

I pointed to my SQL Server and everything looked fine.

Installation failed because the DB was not created.

All Solutions are installed but not configured corectly.

Because there is no Symantec_cmdb reconfigure did not work.

Reinstalling solutions in SIM didnt work either.

I tried to open an ODBC Connection to the SQL Server from my management Server - everything is fine.

Has anybody of you ran into the same problem?

How do i get back to a clean Server without uninstalling every solution by hand?

Is there a way to get back to the solution configuration pointing to an SQL Server in SIM?

I am lost, any help appreciated.



Comments 9 CommentsJump to latest comment

BeatIT's picture

I uninstalled solutions and tried to reinstall the system with an local SQL 2008 r2 instance offered by SIM during Installation.

Again, all rights are set correct and no DB is created during installation.

Am i missing something?

Test of Database connection in SIM showed no error.

Mistral's picture

SP1 installed on your 2008R2 server?

Uninstall SP1 and retry.

BeatIT's picture

SIM told me to do so..


I managed to install CMS with local SQL Server Express 2008 R2 after reinstalling suite from scratch.

Did not change anything to the server so i dont know what was different in my last try.

At least it worked.

Next step would be to move the CMDB to the SQL Server.

Will the following work?

Stop SQL Express DB on Management Server

Copy  DB  and Logfiles to SQL 2008 R2 Server

Mount DB

Open SMC Database Settings and point to the new DB on our production SQL Server

Thnx for any advice.


mclemson's picture

Did you read the Implementation or Migration guides?  I would recommend reinstalling Windows Server 2008 R2 without SP1, then preparing for the SQL installation by ensuring the SQL account you're using has the correct privileges, as defined in the migration guide (ITMS 7.0 Migration Guide page 42).

However, if you're set on migrating the database on day 1, follow the guidance in this KB for NS 7:
How to move an Altiris SQL database from one server to another:

In general you have the correct process defined.  However, in 7.1, it is not recommended to use Database Settings to change databases; rather, they encourage you to use the Database Reconfiguration page in SIM.  You probably will still have SQL authentication/permission issues, however, once you connect it to the new server.  I would recommend working with your SQL DBA to create an account that has the privileges defined in the Migration Guide, then, with a fresh server, allowing SIM to create the 7.1 CMDB for you.

I just wouldn't patch together a brand new server like that when you have the opportunity to do it right.

Link to migration guide:
Zillions of documents on 7.1, uploaded by JMart:
Read "IT Management Suite Migration Guide version 7.0 to 7.1"

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner

Guido Langendorff's picture

In my experience sometimes the SMP installation is failing.  This can have various reasons, most of them are related to security or prerequisits not met.  If so, I always want to go back to a clean environment.  This, in my opinion, is remove all installed applications related to SMP but leave SIM.  Also remove the database and the Altiris Hive in the registry.  !!! Leave THE SIM related data in the registry !!!

For removing the database one can do this in two ways:

- Remove SQL installation and when done remove the folder structure (database are NOT removed after uninstall SQL!)

- Use SQL Management Studio.  This is a tool everybody using MS SQL (whatever version) should have installed.  You need it to set Security and tweak memory, logs, indexes, etc.  And you can remove a database.

After all these steps, restart the installation

First ONLY install SMP.  If this is succesfull, now install CMS, SMS or what ever you whant.

My 2 cents on this.

Have fun!

jpn010@tower's picture

Exact same issue here.  No database created, but SIM has no problems connecting to the DB server and pulling the list of existing databases.  Been trying since Monday morning to get 7.1 SMP installed with no success.  Not only has support not been helpful, they seem to now be ignoring me.  Very frustrating.

mclemson's picture

Same boat.  I've done all the troubleshooting and let them know what the exact issue is.  I just need them to tell me if I should fix it manually, or start with a fresh server.  First level support says they're waiting on second level, but refuses to escalate me directly to second level.  I submitted the incident on Monday, and it's Thursday now.  I've read all of the remaining 7.1 documentation (including the database schema!) while waiting.

The problem is that first level sounds completely helpless.. and kind of sad.  I think they're inundated with calls from people who installed 7.1 or attempted a migration without reading the instructions first.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner

jpn010@tower's picture

Finally got Rasmus on the phone yesterday afternoon and after four hours, he figured it out.  My issue was that, although SIM allows you to specify a custom URL for the SMP during the initial configuration, if you actually change it to something other than the server name (ie, a "friendly" URL), configuration fails (unless you make some registry modifications).  The reason for this is that SIM doesn't connect to the database directly (as it does when you're actually specifying the server/dbname), but calls web services on the SMP box to create and build out the DB.

Hope this helps someone else.

jpellet2's picture

That is exactly my issue. It failed 3 times for me yesterday and I finally left the FQDN alone in the installation manager and the software installed (which it always did) and then configured correctly (which it wouldn't do). Looking at the logs told be that it couldn't contact the specific configuration web page and, sure enough, when I tried manually it failed. As soon as I went to the page using the original URL I could access it successfully.