Video Screencast Help

Site Server will not install Package Service or Task Service

Created: 02 Jul 2013 | 8 comments

I have SMP 7.1 and trying to setup a Site Server.  I have a Server setup with all the proper setting per the documentation.  It just stays in a not installed state when I go to manage the Site Servers.  On another note, I recently and the Package Service option to the NS and all the packages are staying in a pending state.  When i go to the agent it continually states retrying download.  I have restarted the servers, restarted the task associated with this, and reset IIS numerous times.  I get this error in the logs

Error while downloading package: No package sources returned by server (-2147023728)

Operating Systems:

Comments 8 CommentsJump to latest comment

HighTower's picture

How long has it been since you assigned the Task and Package Server installations to the server?  Honestly it takes more time than you would think that it should.

You can somewhat accelerate the installation by doing a delta update and hitting refresh on the agent but the "old timers" on here will probably recommend waiting over night.  If it hasn't configured itself by tomorrow morning that's when you should dig into it.

(Lousy answer, I know).

phoward74's picture

It's been a week.  I have done a delta update, but still no luck.  I've tried everything that is remotely close from the searches on the forums, I think.

David_SES's picture

Hi,

 The best is to copy the task service and the windows package Server agent install directely from the NS to the server. install them on the server.

Then check in settings->notification server->site server settings if the NS see the server.

regards,

fabian.szalatnay's picture

 

Next time try to install the task service first and only after success push the package service agent. I assume now your NS thinks your site server is already package server and tells the package server to get the packages from itself.....but there are no packages ready yet.

Do not interfere the site server install process with constantly klicking on "send basic inventory" and "update configuration". The NS server needs some time to update the internal filters. Otherwise your NS thinks right away that there is a new site server and redirects the package download requests to this new site server.

That way the newly created package server tries to download the package agent from itself, which will -obviously - never succeed.

In this case double klick the package agent install policy on the site server an check out name and parameters of this install package. Look for this EXE-file on the NS server an copy it manually to the site server. Install by using the correct parameters. Like David_SES wrote.

 

Fabian Szalatnay | FYRE Consulting AG | http://www.fyre-consulting.ch

phoward74's picture

So, I was able to get the services to install on the Site Server and be recognized in the SMP.  The problem is both the NS and the SS are pending on package installs.  I have waited a week to post this because I wanted to make sure that it wasnt an impatience issue.  When I look at any of the packages retrying download on the agent, they are trying to install from the NS and its states the packages dont exist.

Falquian's picture

Hi, phoward74:

Have a look at the following article:

http://www.symantec.com/docs/TECH122379

Is this your issue?

Regards:

      Falquian

Kind regards:

     Falquian

If this post is useful to you, remember to mark it as a solution ;)

phoward74's picture

Im afraid not.  In the log viewer, when I go to where it trying to install the packages it is pointing to the NS as the source of the packages and "No package sources returned by server {-2147023728}"  This on both the site server and the notification server.