Video Screencast Help

Slow backup job rate

Created: 06 Feb 2013 • Updated: 11 Feb 2013 | 12 comments
no_name's picture
This issue has been solved. See solution.

Hi,

We have a Netapp device that directly connected to tape via ISCSI and both has a 10 GBlinks. We also set up Exagrid device which also has 10 GB links. Our backup infrastructure is to backup snapshot of volume on netapp filer using B2D (exagrid) then duplicate to tape. 

From the above configuration, we run a test backup of snapshot which has a total size of 1TB of data at first, job rate took 4GB/min then after hours of running job rate was continues to drop from 4GB/min to 102 MB/min. Anyone have suggestion on how are we resolve this is greatly much appreciated. Thanks.

Discussion Filed Under:

Comments 12 CommentsJump to latest comment

no_name's picture

hi pkh, any suggestion please?

pkh's picture

Try to take things one at a time.  Backup the Netapp to some internal harddisk first, not the Exagrid, and see the result.

no_name's picture

Hi pkh,

Can I use direct backup to tape instead of  harddisk. I have no external disk that can accommodate 1TB of data?

pkh's picture

Tape is not too good a test because it may be slower but it is worth a try.

Also try backing some files on the disk rather than snapshots.

no_name's picture

Hi phk, I tried to backup from tape but the result is worst. Do you have any suggestion that I can try since I don't have yet internal harddisk to use for testing.

Also, we only choose one snapshot per volume. I could not backup small snapshot because once I browse it in the selection, it shows as 1 volume only. If i backup the data rathan than snapshot, possible that it will cause slow performance of the production. Thanks

Andrew Madsen's picture

I will assume you are using an SLP. Is your SLP set to:

Backup to Exagrid

  --> Duplicate to tape

Or is it

Backup to Exagrid

Duplicate to tape

 

The first means you backup to the Exagrid and when the backup is finished you will duplicate from the Exagrid to tape in two seperate jobs. The second is you will backup to the exagrid and then to the tape FROM the Netapp in the same job. This sounds like what you are getting. 4GBpm to the Exagrid and then 102MBpm to tape.

The above comments are not to be construed as an official stance of the company I work for; hell half the time they are not even an official stance for me.

no_name's picture

We do backup to exagrid then duplicate to tape. The 4GB/min then drop to 102MB/min still on B2D process.

no_name's picture

We do backup to exagrid first and duplicate data immediately after source task completes.

Andrew Madsen's picture

Does the Job log indicat a change of volume? I do assume this is NDMP backup correct?

The above comments are not to be construed as an official stance of the company I work for; hell half the time they are not even an official stance for me.

no_name's picture

Yes this is NDMP backup.  Not sure what you mean by change of volume, do mean the snapshot of volume?

Andrew Madsen's picture

Ignore the change of volume question. It was my evil side asking things just to sound intelligent. I slapped it down and all is better now.

A different question though: How many streams do you have on the NDMP policy when it runs?

I got to thinking about your configuration and I need to verify something. This is what you originally said:

"We have a Netapp device that directly connected to tape via ISCSI and both has a 10 GBlinks. We also set up Exagrid device which also has 10 GB links. Our backup infrastructure is to backup snapshot of volume on netapp filer using B2D (exagrid) then duplicate to tape"

Do you have the tape library zoned to the exagrid as well as the NetApp device? Or is the tape library zoned only to the NetApp device? 

 

The above comments are not to be construed as an official stance of the company I work for; hell half the time they are not even an official stance for me.

no_name's picture

The issue with the slow throughput rate via ndmp backup has been resolved by changing the LAN connection order in which network services being access.

Here's the steps:

1. Login to media server and from network properties, click "change adapter settings"

2. From menu bar, click advanced -> advanced settings

3. From adapters and bindings, LAN should be moved on the first order.

Currently, the throughout rate of backup was 9GB/min after we do the above steps. Hope it helps to others...

 

 

 

 

SOLUTION