Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Slow throughput on teamed NIC's

Created: 22 Mar 2013 • Updated: 17 May 2013 | 7 comments
This issue has been solved. See solution.

Hello,

I have Backup Exec Small Business 2012 installed on my new media Server SBS2011.

The server has 4x 1 GB NIC on one Teaming Load Balanced.

When I backup a client (Win7 x64 with SSD) it seamed the media-server works on half duplex.

The load is 50 % on NIC2 on reading and about 50 % on NIC 3 with writing to NAS.

But when I copy a big file with windows explorer form \\client\C$ to \\NAS it runs with 99% on reading and writing.

Is it a configuration problem?

Thanks for any help.

Operating Systems:

Comments 7 CommentsJump to latest comment

pkh's picture

If I am not mistaken, BE does not support teamed NIC's.

teiva-boy's picture

Teaming is supported by BackupExec.  However, there are a number of issues reported when teaming is enabled.  So Symantec's frist step, disable it.  This isn't the faut of teaming per say.  But often miconfiguration of the network switch stack (Lack of LACP in the switches), or limitations of the application.

In teaming configurations you have multiple links acting as a fail-over or as an aggregate.  The aggregate only functions when there are multiple streams.  A 4 port 1GbE trunk with a single stream, will only engage a single port within the vIP.  You need to run multiple multiple jobs to disk to see the benefits of teaming.  Just like iSCSI and MPIO.  multiple volumes and applications opening multiple connections are the only way to realize MPIO.

 

That said, there are much more bottlenecks one can address, and teaming is one of the last things to play with IMO.  Getting BackupExec to run fast, is usually not found with networking alone.

http://www.symantec.com/business/support/index?pag...

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

Mar78's picture

Hello teiva-boy,

your'e in right, I don't expect 4 GbE throuput, because the clients still have one GbE-Port. In BE2012 storage-window I set to use 2 simultanous write-sessions.

But I don't understand the different throughput when I copy with explorer in full-duplex and with BE 2012 in half-duplex. Therefore I think that its of cause of BE 2012.

Its the same workstation (with SSD) and the same NAS I used for both tasks.

Does anyone have full-duplex while a backup job on 1GbE?

Thanks for any help

Mar78's picture

Hello,

I've disabled the teaming mode, but there is no effect in the throughput.

It seamed there is any hidden switch to use only 50% of 1GbE bandwith.

I 've created a 10 Gig file and copy it on the mediaserver from my Client-SSD to the NAS with windows explorer with 99 %.

To compare the copyrate with Backup Exec I create a new job and select only that one test-file with no shadow option or any else (like compression).

Symantec Backup Exec copy it with constant 48-52% of 1 GbE bandwith. Than I made a Backupcheck with round about 60%. I also checked the load of the mediaserver (SQL, HDD, RAM, CPU other jobs) - but its all ok.

I cant find any switch to reduce or enhance the throughput.

Symantec, please help me to solve that very slow performance.

Question to users: Has anyone a larger bandwith and what for advices can you tell me?

 

Thanks to symantec and to all users, who can help!

teiva-boy's picture

You could try turning off the restart feature in BackupExec.  I think it's on by default.

Outside of that, TCP tuning would be the next step.  like jumbo frames or the like.

 

 

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

Mar78's picture

Hello, sory for late my answer,

I have all done. but the NIC utilization is alway by 50%.

Taskmanager.jpg

I have found a similar thread:

http://www.symantec.com/connect/forums/speeding-backup-disk-over-network

and make some recommended settings, but nothing helps.

Any help?

Mar78's picture

I have find the solution. That was a long way for me so I want to tell you how it works for me.

first step my configuration:

The NAS box is connected to one NIC of my Media Server with 1 GBit / s with a crossover patchcable.

The other NIC of my Media Server is connected to the companyswitch with 1 GBit / s.

Teaming is inactive. The NIC port 3 and 4 are also disabled. The Media Server is a HP ML 350 Gen 8.

Between NAS ans Media Server I set jumbo frames to 9 KB. To the Company Switch I set it to default (1,5).

 

In Backup Exec in the storage tab click on details and take the following settings:

block and buffersize both on 1 MB

buffered read and buffered write

simultanous writings: 2

(filesize: 10 GB).

After that I create a Pool and select a second path on the NAS (same settings as before). Than I edit the backup job to backup the the pool.

The Backup job are with software compression, MS Windows shadow copy and without fixpoint restart-setting. I backup also open files.

Now the runs with 70-80 percent or 5500 MB/min fast enough.

I hope this helps other with the same problem.

Taskmanager_0.jpg

SOLUTION