Video Screencast Help

SLP backlog missing after upgrade from Netbackup 7.0.X to Netbackup 7.5

Created: 28 Mar 2013 • Updated: 02 May 2013 | 8 comments
demo4119's picture
This issue has been solved. See solution.

I have upgrading netbackup 7.0.1 master server to 7.5.0.5 and found that all my incomplete SLP jobs are missing but the images are still intact with infininty expiration .

I have tried to run the bpexpdate -recalculate -backupid abc_121232334 -ret 11 -force but the first copy images expiration still showing infinity but the media ID has updated with retention 11.

But when i run the bpimagelist -L -backupid abc_121232334 expiration date still showing the orginal , which is 4 weeks.

Is there a way to get back those missing jobs and manual run the duplication to tapes ?

Will extend the tapes media id retention images in the tapes?

Operating Systems:

Comments 8 CommentsJump to latest comment

Mark_Solutions's picture

It is possible that the images were controlled by a different version of the SLP and so have now been orphaned in effect.

You could confirm that by querying them with the nbstl -L -allversions command and see how many versions you have.

The upgrade probably made a new version of the SLP due to SLP changes

This means the images that had not completed their lifecycle have been orphaned - you will need to pipe a list of all of them and then cancel them using the bpstlutil command adding the -version swicth to get it to work

You will then be able to manually duplicate them

Unfortunately you cannot change the version numbers anywhere so if this has happened to you there is no other route to get around it

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
demo4119's picture

Hi Mark

We did a check with symantec support before this upgrade
anyway you have provide me a very detail explanation .

I will try it out and log case with support is required.

Mark_Solutions's picture

OK - if it is a version thing, and it sounds like it, there is no workaround so your only option is to cancel them all and manually duplicate them - the trick is to see if the unduplicated images are using a different version number than the current one and if so add the -version switch with the cancel command otherwise they don't cancel

Then just run the duplication against all of those images

A few batch files comes in handy here!

Keep us updated

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

demo4119's picture

Hi Mark

when i run the nbstlutil -U -image_incomplete there isnt any SLP backlog images shown before the upgrade date and time.

Thanks alot.

demo4119's picture

Hi Mark

Strange thing happen as below.

When we run the bpimagelist -U -stl_incomplete there only recently backlogs shown which is very few.
But when i run the nbstlutil stlilist -U -image_incomplete , it can list out all the SLP incomplete jobs.

Before the netbackup 7.5 upgrade i can run the bpimagelist -U -stl_incomplete to check the daily backlogs queue.

Did you ever encounter this before?

Mark_Solutions's picture

There have been some changes in functionality between the versions

Also, I believe only the nbstlutil command deals with versions and so the bpimagelist command may well be reporting back on the current SLP version only

Sounds like you do have some work to do after all!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

demo4119's picture

I have checked that the bpimagelist -U -idonly -stl_incomplete will only list one day incompleted slp queue . Unless the previous version . I have tried to use the parameter of -d and -e still not able to query the date range. 

But when i use the parameter -hoursago 480 it work well.

I agreed with you that the nbu command seem to be changed on the new version .

Mark_Solutions's picture

Not sure on that one but a lot of commands, if you do not specify dates, just defaults to a 24 hour period

I do prefer the -hoursago as you can use some very large numbers for that!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.