Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SLP LIFECYCLE_PARAMETERS not working correctly

Created: 23 Oct 2012 • Updated: 24 Oct 2012 | 4 comments
This issue has been solved. See solution.

I'm working at a new company and they have SLP's running without LIFECYCLE_PARAMETERS conf file there so I added it the other day with just the default setting for now.

MBU 7.1.0.4

Windows 2003

The problem I'm seeing is it's not affecting the job process at all, I didn't think the services would need to be recycled for it to take affect or is there something else going on.

I keep seeing duplication jobs not batching up at all.

Thanks for any help..... Dan

LIFECYCLE_PARAMETERS

    MIN_GB_SIZE_PER_DUPLICATION_JOB 8
    MAX_GB_SIZE_PER_DUPLICATION_JOB 25
    MAX_MINUTES_TIL_FORCE_SMALL_DUPLICATION_JOB 30
    DUPLICATION_SESSION_INTERVAL_MINUTES 5
    IMAGE_EXTENDED_RETRY_PERIOD_IN_HOURS 2
    DUPLICATION_GROUP_CRITERIA 0
    TRESHOLD_JOB_COUNT 100
    SESSION_RUN_TIME_MIN 60

Comments 4 CommentsJump to latest comment

Marianne's picture

Adding LIFECYCLE_PARAMETERS with default values is the same as not having the file at all.

Maybe increase MIN_GB_SIZE_PER_DUPLICATION_JOB as a start? 

From the Best Practice Guide:
If the MIN_GB_SIZE_PER_DUPLICATION_JOB setting is small, more duplication jobs are created. If it is large, fewer, larger duplication jobs are created.

PS: double-check that Windows Explorer did not add .txt extension to the filename...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Nicolai's picture

Where have you placed the LIFECYCLE_PARAMETERS file. It must be located in [Install_path]\netbackup\db\config on the master sever.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

bigblockdan's picture

It's in the correct location... \netbackup\db\config

I did make sure it didn't have an extention see that before also.

Marianne I changed the values and in the process of testing it out.

bigblockdan's picture

That did it I guess I was just looking at the one tree in the forest :)