Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

SMP 7.1 SP2 - Staging of MS12-034 fails

Created: 01 Oct 2012 • Updated: 09 Oct 2012 | 3 comments
rjac's picture
This issue has been solved. See solution.

One of our customers receives an error when he stages MS12-034. This happens to this item only. Staging Software Update for MS12-034 - Status: failed. The Notification Server Log reports the following:

Log File Name: C:\Windows\system32\Altiris Logs\a36.log
Priority: 1
Help and Support:
Date: 26.09.2012 10:03:42
Tick Count: 86707274
Host Name: SWOLACM1
Process: AtrsHost (1448)
Thread ID: 411
Module: AtrsHost.exe
Source: Altiris.PatchManagementCore.Tasks.Server.DownloadSWUPackageTask.DownloadUpdate
Description: Failed to download the update Silverlight51104110_x64.exe (054b104c-9a29-427e-949d-0c8de7ca056e) -> Object reference not set to an instance of an object.

( Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.
   at Altiris.PatchManagementCore.Tasks.Server.DownloadSWUPackageTask.DownloadPackage(PatchSoftwareUpdateResource softwareUpdate, OperationProgressIterator progress)
   at Altiris.PatchManagementCore.Tasks.Server.DownloadSWUPackageTask.DownloadUpdate(PatchSoftwareUpdateResource pSoftwareUpdate, OperationProgressIterator progress) )
( Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.PatchManagementCore.Tasks.Server.DownloadSWUPackageTask.DownloadUpdate(PatchSoftwareUpdateResource pSoftwareUpdate, OperationProgressIterator progress)
   at Altiris.PatchManagementCore.Tasks.Server.DownloadSWUPackageTask.ProcessPackages(ProcessPackagesRezult rezult)
   at Altiris.PatchManagementCore.Tasks.Server.DownloadSWUPackageTask.OnExecuteSingleton(IServerTaskExecutionInstance instance)
   at Altiris.PatchManagementCore.Tasks.Server.SerializingBaseSingletonServerTask`2.OnExecute(IServerTaskExecutionInstance i)
   at Altiris.TaskManagement.ServerTasks.BaseServerTask.OnExecute(ITaskExecutionEngine engine, IServerTaskExecutionInstance instance, TaskInstanceRequest request)
   at Altiris.TaskManagement.ServerTasks.BaseServerTask.Execute(ITaskExecutionEngine engine, IBaseTaskExecutionInstance instance, TaskInstanceRequest request)
   at Altiris.TaskManagement.Common.Execution.Engine.TaskEngineExecutionThread.ExecuteTaskHandler()
   at Altiris.TaskManagement.ServerTasks.ServerTaskExecutionThread.ExecuteTaskHandler()
   at Altiris.TaskManagement.Common.Execution.Engine.TaskEngineExecutionThread.OnExecute(Object eventComplete)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart(Object obj)
( Extra Details:  Type=System.NullReferenceException Src=Altiris.PatchManagementCore )

We tried to repair patch management solution via SIM and did a "aexconfig.exe /configureall" - but the situation did not change.

Does anyone has the same problem or some suggestions for this issue?

Comments 3 CommentsJump to latest comment

claus66's picture

We've got the exact same problem - did you resolve it?

Roman Vassiljev's picture

Hello rjac,

Thank you for your post.

This issue may occur in case if Microsoft vendor is not fully selected in Import Patch Data task settings.
To resolve this issue navigate to Manage > Jobs and Tasks > System Jobs and Tasks > Software > Patch Management > Import Patch Data for Windows page > tab 'Vendors and Software' and select software release 'Microsoft Silverlight 5 (x64)' under Microsoft vendor.
Save changes and execute PM import task.

Best Regards,

rjac's picture

Thanks Roman! Worked well!