Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SMP Agent not registering to itself

Created: 21 May 2013 • Updated: 22 May 2013 | 2 comments
This issue has been solved. See solution.

Recently discovered that the NS Agent on the SMP is no longer able to register to itself. I have tried everything that I can think of to get it to register but nothing is working.

 

 
The error I am seeing in the logs is:
 
Invalid data received in HTTP response. Expected 3888 bytes, received 0 (-2147024883)
 
I think their may be an issue with the ClientTaskServer as whenever I tried to navigate to:
 
http://ServerName/Altiris/ClientTaskServer/GetComputerCount.aspx
 
I get a request timed out error. 
 
I have already followed the solutions provided in KB:
 
TECH42308
 
HOWTO32603
 
TECH191234
 
I am at my wits end as I have tried everything that I know usually resolves these types of issues but it still persists.
 
Thanks for any insight.
Operating Systems:

Comments 2 CommentsJump to latest comment

W007's picture

does this help

Detection and Applicability rule failures: Invalid data received in HTTP response. Expected 27 bytes, received 0 (-2147024883)

Article:TECH188097  |  Created: 2012-05-04  |  Updated: 2013-03-22  |  Article URL http://www.symantec.com/docs/TECH188097

 

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

sarquiss's picture

Hi Manish,

That article doesn't apply as the error is different. Additionally, the Detection and Applicability Rules do work when the agent gets registered.

However, I was able to resolve the issue. I noticed a flood of warnings in the Altiris logs regarding a Socket Exhaustion issue. I checked all of the sockets and everything seemed fine. In the end I discovered that a replication job was causing the issue. So once I got that sorted everything worked :)

SOLUTION