Video Screencast Help

SMP does not register itself to Task Server

Created: 28 Apr 2014 • Updated: 02 Jun 2014 | 18 comments
This issue has been solved. See solution.

Hi,

The NS does not want to register itself to its task server.

agent_task_server.JPG

The agent log does show a warning which I have not seen earlier:

Server ID '{6E97D571-F3C1-4ec4-AEDE-DD9719B02277}' is not valid

agent_log.JPG

Anyone seen this warning before? Maybe it has nothing todo with the problem itself but it seems to occur directly after pressing the "Resent Agent" button.

Stefan

Operating Systems:

Comments 18 CommentsJump to latest comment

SK's picture

What does the "NS Web Config" tab show?

Also, search the Altiris registry for that Guid to see if it exists anywhere in there or not.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Igor Perevozchikov's picture

You can check what ID is there [HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Communications\Servers]

Maybe your SMP Server has changed IPv4/IPv6 address and now CTA shows that Server ID is not valid (It should be auto-resolved after sometime)

Also you can check profile state of this server in your SMA:

  • C:\Program Files\Altiris\Altiris Agent\AeXNSAgent.exe /diags
  • Mouse right click menu on SMA systray icon ⇒ Network Diagnostics ⇒ Server Profiles
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Stefan S.'s picture

It seems like this is a predefined ID for the server which is the Task Server. I can see the same ID on my other 2 child NSs which both have a Task Server.

The "ID" is missing under the "HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Communications\Servers". I have tried to add the "missing" regsistry keys with the mentioned ID but the Altiris Agent removes it directly again saying server marked for deletion.

One other thing was strange to begin with when I registered the "diags" I did not have the "network connections" tab in the Symanntec Management Agent. I unregistered and registered again and then I could see the "diag" paste.

BTW: SMP Version is 7.5 HF3 (Task Server version 7.5.1673)

Igor Perevozchikov's picture

I've seen such warning message Server ID '{}' is not valid on my SMP Server after update from 7.5 HF5 to 7.5 HF6 but I also see that SMA on local SMP server has been successfully registered with Local Task Server.

You mean that you're still unable to register local SMA on SMP Server with local Task Server even after a few days?

  • Restart local SMA?
  • Restart "Altiris Object Host Service"?
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Stefan S.'s picture

Yeah I still have the probelm. I have restarted both SMA and Task Services. I also have restarted the server.... Even if I "manually assign" the SMP to itself it does not register.

As it seems to me otherwise that task service is running and working because when I  navigate to "http://localhost/Altiris/ClientTaskServer/GetComputerCount.aspx" it gives me the count of connected clients.

I was thinking to reinstall the SMA on the SMP but this is normally not advised...

Igor Perevozchikov's picture

Also, other clients are able to register with this same SMP local TS or this problem occurs only with local SMA on SMP Server?

  • You can try to delete all available profiled servers from registry and restart local SMA, then SMA should re-profile all of them once again.

Re-Profile_Registry_0.jpg

  • Try to ResetGuid for local SMA on SMP Server ⇒ C:\Program Files\Altiris\Altiris Agent>AeXNSAgent.exe /ResetGuid
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
tzamarin's picture

After working till 1AM applying HF5 last night and this happening to us globally, HF6 released today and it fixed the issues with the site servers not checking into any task server, so you might want to apply HF6.  Also a trick we also caught while on the phone with support is that under the SIM on your NS, change the filters to show product version.  Our task server x64 agent was broken, we ran the MSI and did a repair and that fixed our agent as well

Stefan S.'s picture

HF3 was installed for a while and we didn't have this problem. It started somehow this week. Strange that this pops up out of nothing.... I guess I will have to do the same and create a case with support and hope they can help without the pain of installing the next couple of HF which normally break something else additionally to fixing one thing.
 

Igor Perevozchikov's picture

Hi Stefan,

any update on this problem? Did you resolve it? What was a problem?

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
sergei Z's picture

Guys,

This error "Server ID '{6E97D571-F3C1-4ec4-AEDE-DD9719B02277}' is not valid" has nothing to do with the registration failure, you;'re looking in the wrong direction.  This is just an unfortunate  cosmetic issue. Adding the "missing" key will not help much.

Could you please enable debug logging on the agent, hit "reset agent" button, wait few minutes and then send the logs here? I think the log will have some useful info because the task agent should connect or not connect to the task server and get or don't get some response.

thanks!

sergei

sergei zjaikin, senior principal software engineer, symantec

Stefan S.'s picture

@Igor: The problem still exists.

@sergei Z: You received the SMA and SMP logs via private message.

Alex Bizjajev's picture

Hi Stefan,

May you check web-site Altiris\ClientTaskServer advanced settings: which ApplicationPool is assigned to it? Then check settings of that appool - it should work in "Classic" mode.

Thank you,

Alex.

gshpakov's picture

Hi Stefan,

we are reviewing the logs that you provided and would like to request additional information.

Could you send the output of the following query from your Symantec DB:

SELECT

            ra.[ChildResourceGuid] AS [ResourceGuid],

            ra.[ParentResourceGuid] AS [TaskServiceResourceGuid],

            cts.[ClientTaskServerGuid],

            [dbo].[fnTM_GetComputerResourceFQDN](cts.[ClientTaskServerGuid]) AS [FQDN]

                          FROM

            [dbo].[ResourceAssociation] AS ra

          LEFT JOIN [dbo].[Inv_Client_Task_Servers] AS cts ON cts.[_ResourceGuid] = ra.[ChildResourceGuid]

          LEFT JOIN [dbo].[SecurityResourceProtection] AS srp ON cts.[_ResourceGuid] = srp.[ResourceGuid]

          WHERE

            -- site server computer resource association type guid for Task Service

            [ResourceAssociationTypeGuid] = '5F00E96B-93F3-41F0-94A7-7DBBB8AEF841'

Thanks in advance,

Grigory.

Stefan S.'s picture

Thanks all for your support.

It seems like I got it working again. The last 2 steps I took which I remember....

1. I have found the following article http://www.symantec.com/docs/TECH203322 when running the SMPDiag.exe on the SMP. This article points to some "unfinished" site servers wich I then cleaned-up

2. I have added the affected SMP as an "manual" assignment to itself

... and voila I came back from lunch and suprisingly saw the SMP was registered to itself. yes

Problem solved...

SOLUTION
Alex Bizjajev's picture

Hi Stefan,

It's good to see you have managed to solve the problem. We did some research and believe this issue has been fixed in 7.5.SP1.

Thank you,

Alex.

Stefan S.'s picture

7.5 SP1 is due in June / July the last time I asked is that still the case?
 

andykn101's picture

"ITMS 7.5 SP1 Release Preview Information"

http://www.symantec.com/docs/HOWTO96437

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.