Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Snap Driver issue on Netbackup 7.5 Upgrade for 7.0

Created: 14 Mar 2013 • Updated: 04 Apr 2013 | 1 comment
This issue has been solved. See solution.

Hi everyone!

Just wondering if I can get some help on an issue while trying to upgrade a Netbackup 7.0.1 Media Server to 7.5.

When I run the install for 7.5 I get the message below:

=== Removing pre-existing package ====

WARNING:  The NetBackup snap driver is busy.  Wait for all active
WARNING:  snapshots to complete and then re-try the pkgrm.
pkgrm: ERROR: preremove script did not complete successfully
 
Removal of <SYMCnetbp> failed.
 
I've disabled and deleted the snapshot policy I had running on my old 7.0 environment but this doesn't seem to help.
I know this is probably some little thing I'm not aware of but....
 
How can I locate the active snapshot process that's causing this?
 
Thanks
Operating Systems:

Comments 1 CommentJump to latest comment

Dyneshia's picture

How To ID: HOWTO69500
Version: 1.0
Status: Published
Published date: 02/07/2012

Removing stale snapshots (Solaris)
On Solaris, if your cache partition runs out of space, stale snapshots may be taking up space on the cache partition. Stale snapshots are those that FlashBackup did not automatically delete.

To remove stale snapshots (Solaris)

Determine if there are stale snapshots on your Solaris client by executing the following:

/usr/openv/netbackup/bin/driver/snaplist
For each snapshot that is listed, run the following to make sure a bpbkar process is associated with it:

ps -eaf |grep identwhere ident is the snapshot process id displayed by the snaplist command.

Remove snapshots that do not have an associated bpbkar process by entering the following:

/usr/openv/netbackup/bin/driver/snapoff snapn
where snapn is the snapshot id displayed by the snaplist command.

SOLUTION