Video Screencast Help

Snapshot could not be created with auto method

Created: 25 Nov 2009 • Updated: 04 Jun 2010 | 9 comments

Hi all .

I've netbackup 6.5 on window server 2008 and netbackup lient on Solaris 10 64bit .
I've tried to backup snapshot for solaris server by backup policy type standard  with  parameters in backup selection :    Cache=/dev/rdsk/c1t1d0s3 ,/var .
Then netbackup information is : Snapshot could not be created with auto method.
Then I've tried to creat snapshot on solaris server :    /usr/openv/netbackup/bin/driver/snapon /var   /dev/rdsk/c1t1d0s3  
                                                                                               But failed: Cannot find module (snapctl).
                                                                                                                   add_drv command failed.

Please help me .

Thanks .

Comments 9 CommentsJump to latest comment

Nicolai's picture

I have tried a similar setup  on Linux and HP-UX , both where tricky  to get working (using VxFS file system) . You need to look in the bpifs debug log on the client. 

You can enable the log  by crating a directory called bpfis in /usr/openv/netbackup/logs , then add VERBOSE = 5 to bp.conf

You may also find assistance in the Netbackup Snapshot client admin guide chapter 7.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

vietanhhnus's picture

Dear  bpfis  .
Could you tell me the way details  creat log on Client run Solaris ?

brant's picture

1. On your solaris (NBU Client), run /usr/openv/netbackup/logs/mklogdir
2. On NBU Master server side, run /usr/openv/netbackup/bin/jnbSA &
3. Navigate: Master Server -> NetBackup Management -> Host Properties -> Clients -> Select your solaris machine, right click it -> Propertiese -> logging, enable robust logging , global logging level is Five, Database logging is same with global. Save this conf by click OK.
4. Then restart all NBU services on solaris.

Then you do your operations, then you'll get bpfis logs at /usr/openv/netbackup/logs/bpfis/.

Hope this can do a little help.

Best Regards,
Brant.

---------------------------------------------------

Please kindly close this thread if it has been resolved.

Just mark the right answer as the relolution and thumds up.
O(∩_∩)O~

----------------------------------

vietanhhnus's picture

Dear Brant!
Thanks  for help .
I've enabled log on netbackup client .However I can't troubleshoot the  problem.

My System used :    1.Master Server  on Windowserver 2008  and connect to Tape Library .
                                    2. Client Server used Solaris 10  .
I want to create snapshot backup policy on Netbackup :   
                                     Type Policy :  Standard 
                                     Snapshot method :   nbu_snap
                                     Backup selection  :     /var  , CACHE=/dev/rdsk/c1t1d0s3
but  fail  : 
Snapshot could not be created with auto nbu_snap .
Could you help me for troubleshoot it ? 

Thanks and Regards  .
Have a weekend !

                                   

brant's picture

Hi vietanhhnus,

Could you please upload the file ?
If more logs available, more clues can be found, even I am not familer with Snapshot  nbu_snap ⊙﹏⊙

Thanks.

---------------------------------------------------

Please kindly close this thread if it has been resolved.

Just mark the right answer as the relolution and thumds up.
O(∩_∩)O~

----------------------------------

brant's picture

Hi vietanhhnus,

Could you please upload the bpfis logs?
If more logs available, more clues can be found, even I am not familer with Snapshot  nbu_snap ⊙﹏⊙

Thanks.

---------------------------------------------------

Please kindly close this thread if it has been resolved.

Just mark the right answer as the relolution and thumds up.
O(∩_∩)O~

----------------------------------

vietanhhnus's picture

Hi Alan .
THis is the log file when I created snapshot policy : 
12/3/2009 9:23:32 PM - requesting resource  server_storage -hcart-robot-tld-0
12/3/2009 9:23:32 PM - requesting resource server_storage.NBU_CLIENT.MAXJOBS.client_1
12/3/2009 9:23:32 PM - requesting resource server_storage.NBU_POLICY.MAXJOBS.snaphshot
12/3/2009 9:23:32 PM - granted resource server_storage.NBU_CLIENT.MAXJOBS.client_1
12/3/2009 9:23:32 PM - granted resource server_storage.NBU_POLICY.MAXJOBS.snaphshot
12/3/2009 9:23:32 PM - granted resource 0032L4
12/3/2009 9:23:32 PM - granted resource HP.ULTRIUM4-SCSI.001
12/3/2009 9:23:32 PM - granted resource server_storage-hcart-robot-tld-0
12/3/2009 9:23:33 PM - estimated 0 kbytes needed
12/3/2009 9:23:33 PM - begin Parent Job
12/3/2009 9:23:33 PM - begin Snapshot , Start Notify Script
Status 26
12/3/2009 9:23:33 PM - end Snapshot , Start Notify Script; elapsed time: 00:00:00
12/3/2009 9:23:33 PM - begin Snapshot , Step By Condition
Status 0
12/3/2009 9:23:33 PM - end Snapshot , Step By Condition; elapsed time: 00:00:00
12/3/2009 9:23:33 PM - begin Snapshot , Stream Discovery
Status 0
12/3/2009 9:23:33 PM - end Snapshot , Stream Discovery; elapsed time: 00:00:00
12/3/2009 9:23:33 PM - begin Snapshot , Read File List
Status 0
12/3/2009 9:23:33 PM - end Snapshot , Read File List; elapsed time: 00:00:00
12/3/2009 9:23:33 PM - begin Snapshot , Create Snapshot
12/3/2009 9:23:33 PM - started process bpbrm (304)
12/3/2009 9:23:36 PM - begin Create Snapshot
12/3/2009 9:23:37 PM - Warning bpbrm(pid=304) expected start message from client_1; read: ERR - NetBackup libonline_util library not installed: ld.so.1: bpfis: fatal: /usr/openv/lib/libonline_util.so: open failed: No such file or directory
12/3/2009 9:23:37 PM - end Create Snapshot; elapsed time: 00:00:01
12/3/2009 9:23:38 PM - end writing
Status 9
12/3/2009 9:23:43 PM - end Snapshot , Create Snapshot; elapsed time: 00:00:10
12/3/2009 9:23:43 PM - begin Snapshot , Stop On Error
Status 0
12/3/2009 9:23:43 PM - end Snapshot , Stop On Error; elapsed time: 00:00:00
12/3/2009 9:23:43 PM - begin Snapshot , Delete Snapshot On Exit
Status 0
12/3/2009 9:23:43 PM - end Snapshot , Delete Snapshot On Exit; elapsed time: 00:00:00
12/3/2009 9:23:43 PM - begin Snapshot , End Notify Script
Status 26
12/3/2009 9:23:44 PM - end Snapshot , End Notify Script; elapsed time: 00:00:01
Status 9
12/3/2009 9:23:44 PM - end Parent Job; elapsed time: 00:00:11
an extension package is needed, but was not installed(9)

Please help me !

Nicolai's picture

You need to installed the snapshot client package on the client - it's a extension package to the file system client. This will also resolve the "an extension package is needed, but was not installed(9)" message you are seeing.

The snapshot client is located in the NetBackup_Enterprise_Server NB_SNC_6.5{something} installation file.

Here are two link to assist you:

Snapshot quick start guide See chapter 2 "Installation"

Symantec NetBackup Patch Level Directory (English Locale Only)

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

vietanhhnus's picture

Hi Nicolai!

Which the package I need chose to install on client  in Symantec NetBackup Patch Level Directory

Thanks .