Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Snapshot technology error (0xE000037D): ON SQL

Created: 11 Apr 2013 | 10 comments

Hi

When i run a full backup on BE12 of my Management information system, i get the following errors

V-79-57344-893 - Snapshot Technology: Initialization failure on: "SIMSSRV.school.local\SIMS2008". Snapshot technology used: Microsoft Volume Shadow Copy Service (VSS).
Snapshot technology error (0xE000037D): An attempt to connect to SQL Server has failed.  The logon account may have invalid credentials, or the logon account may have been applied to the wrong resource.

Check the Windows Event Viewer for details.
 

I have checked the credentials and they come through fine on the tests. I dont know what i can try.

Any ideas?

Operating Systems:

Comments 10 CommentsJump to latest comment

VJware's picture

Does the account have appropriate permissions to back the SQL dB such as sysadmin, db_owner etc ?

harps's picture

Im not sure.. How can i check? im not an SQL supremo

VJware's picture

Connect to the SQL instance via SQL Management Studio. (If the Studio is not present, it can be downloaded & installed)

Expand Security - Logins. See if the Backup Exec account is listed here or not.If not, add it. Once it is added, right-click and choose Properties. Choose Server Roles on left-side & provide sysadmin. Then choose User Mapping on left side & provide db_owner, db_datareader, db_datawriter for the SQL databases.

CraigV's picture

...and also make sure that you're not using AOFO in your job. If you are, turn it off and perhaps look at splitting your backup data off from each other, assuming you're backing up data and databases in the same job.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

harps's picture

Hi

Ive gone into there and ive made sure the SA (system admin) account is there which is what i enetered in to BE12. ive added the required priviledges. now im getting an error from the amanagement studio when i select ok to apply the changes to the database

TITLE: Microsoft SQL Server Management Studio
------------------------------

Add member failed for DatabaseRole 'db_datareader'.  (Microsoft.SqlServer.Smo)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.0.1600.22+((SQL_PreRelease).080709-1414+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Add+member+DatabaseRole&LinkId=20476

------------------------------
ADDITIONAL INFORMATION:

An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

------------------------------

Lock request time out period exceeded.
Cannot use the special principal 'dbo'. (Microsoft SQL Server, Error: 1222)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.00.1600&EvtSrc=MSSQLServer&EvtID=1222&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

Any further ideas? 

pkh's picture

It would be easier to enable Windows Authentication in your SQL.

harps's picture

Any ideas how i would go about enabling windows authentication?

Cheers

harps's picture

You guys are HEROS!

Looked at authentication and found it was set to SQL and Windows authentication. So i decided to try making a new windows based account within management studio and gave it all the permissions you said. IT WORKED!

Thanks ever so much