Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Soft Ignition Key Error with PGP Universal 3.0.1

Created: 23 Mar 2011 | 4 comments

Ever since we upgraded we keep running into a problem where the PGP Universal server wants to be unlocked every morning with the soft ignition key phrase.  This gets very frustrating as not only can new users not register until this happens, but our nightly reports aren't running and neither are our backups.  I went through the logs and this is the error that repeats over and over again:

 



SOAP Fault: returning fault code -2 (locked) from GetIgnitionSecret message

Until the server gets unlocked.  Has anyone run into this/does anyone have a fix or any idea?  My google-fu has failed me with this one so far.

Thanks.

Comments 4 CommentsJump to latest comment

debugme's picture

hi,

we're having the same issue the last weeks. Pretty annoying. Opened a Case with Symantec Support.

the version is 3.0.0 Build (2881)

 

after analyzing the problem, the answer from the support was: "the problem is getting caused by an known issue with the smart card libraries. This problem was solved in a newer version". We should update to 3.1 SP1

maybe thats your issue too? We will try updating

 

an extraction from the core dump files for this error:

Thread 5 (Thread 0x332ab90 (LWP 2238)):

#0  0x005268dc in nanosleep () from /lib/libpthread.so.0

#1  0x00317794 in ?? () from /usr/lib/libpcsclite.so.1

#2  0x003159c9 in SCardGetStatusChange () from /usr/lib/libpcsclite.so.1

#3  0x00fce0d2 in aseSCardGetStatusChange () from /usr/lib/libASEPKCS11.so

#4  0x00fce2d3 in PcscTalker::waitForCardEvent () from /usr/lib/libASEPKCS11.so

#5  0x00f66528 in ASETalkWaitForCardEvent () from /usr/lib/libASEPKCS11.so

 

i hope that could help you

dceboyle's picture

Thanks so much for your reply!

We are actually on 3.0.1 (build 5001) and when we upgraded was when we actually started having this problem.  So while I hope it fixes it for you, it actually CAUSED it for us!

debugme's picture

hi,

updating to 3.1.2 SP2 seems to have solved the problem. The gateway is working for 2 weeks without prompting to enter the ignition key

i suppose its a bug in the 3.0 version.

regards

dceboyle's picture

Sadly this issue has come back with 3.1.2 build 9.  It's up for weeks then suddenly the ignition key problem will come back and will only be fixed by someone logging in and providing the password.  Really annoying.