Video Screencast Help

Software library in heirarchy

Created: 13 Nov 2012 • Updated: 16 Nov 2012 | 6 comments
SonicGT's picture
This issue has been solved. See solution.

I have 1 share that I am using for the software library at my parent server.  The child servers do not appear to be getting any packages I add to the library.  They get the pacakge and all but not the files so they don't replicate down to the package servers.  Do I need to point the child NS to the library in the configration as well, or is there another setting.  Just wondering if I have a possible issue, or just a configuration issue on my part.

Comments 6 CommentsJump to latest comment

Dmitri Dragunov's picture


You do not need to define the same UNC shared folder for software library on the child NS server. Child package servers should download the packages directly from Parent package servers. Please make sure that you can access Parent package server from Child package server(computer is resolved by FQDN and you may open UNC share with packages or access package source by HTTP).

Also you may see on the agent logs for more details. You may find them on the child package server by next location: "C:\ProgramData\Symantec\Symantec Agent\Logs".



SaschaH's picture

Is the Package Service running on the Parent NS? Its a prerequisit of Hierarchy but you never know. If its running try to access packages via HTTP or UNC from the Child NS as Dimitri suggested.

Bechtle – your strong IT partner. Today and tomorrow

If that seems to help, please "Mark as Solution"

SonicGT's picture

So I am still waiting (3 days now) for support to respond to the ticket I opened.  But after checking some more I do see that some of the packages from the parent made it to the childrens package server, and some didn't.  This is without adding the unc of the software library to the child servers.  The packages that did make it did get the package from the parent package server.

Dmitri Dragunov's picture


Did you check the package availability on Parent Package Server from Child Package Server?

Also may I ask you to verify problematic package site server assignment on the parent NS server? Which type of assignment is selected? For proper package distribution should be selected "All Package Servers" or "Package Servers automatically with manual prestaging". 
You may find this by using next steps:
  1. On the Parent  NS server open the problematic Software Release for editing and go to Package tab. 
  2. Select the package and click on edit button(pencil)
  3. Open Package Server tab
  4. Verify  "Assign package to" combo box. For proper package distribution should be selected one of the assignment types described before.
After apply changes you should Update Configuration on NS agent and on Parent Package server agent before replication of changes to child NS server. 



SonicGT's picture

The packages are assigned to be automatic.  The packages themselves show up on the child site servers but the logs indicate "No package sources returned by server"

I did just notice after the last upgrade I did with MR1 I didn't enable the task and package upgrade tasks, so just did that; however, that didnt appear to resolve the issue.  Also getting the same error on just the inventory agent package on the parent servers package server.

*EDIT*  just checking now and automatic may not be selected for all.

fixing and will let you guys know if this is the solution

SonicGT's picture

Thanks Dmitri,

That was the solution.  The inventory agent package was a little different the path was wrong, I think this was due to a package import that tech support had me do for another issue I was seeing.